Editor generates illegal html when pasting lists

VERIFIED DUPLICATE of bug 47014

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 47014
18 years ago
17 years ago

People

(Reporter: Akkana Peck, Assigned: Joe Francis)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Create a list with three items.
Select from the middle of the first item, through the second, and into the
third.
Copy, and paste somewhere else in the document.
You'll get source like:

ne

<li>two</li>

three<br>

... in other words, <li> tags without an enclosing <ul>.

I'm not sure whether the first and third items should have their list tags
included or not in the copied text, but either way, the editor shouldn't allow
inserting list items without generating an enclosing list.

(This probably holds for table cells/rows, too.)

Comment 1

18 years ago
setting to m18 for now
Target Milestone: --- → M18
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
dup of 47014


*** This bug has been marked as a duplicate of 47014 ***

Comment 3

18 years ago
verified in 7/31 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.