Fast Dial add-on prevents current page URL from being displayed in Nav Address bar.

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Plugins
--
major
RESOLVED INVALID
10 years ago
2 years ago

People

(Reporter: Doug Thompson, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Fast Dial 2.11 (and maybe earlier) prevents the Nav Address toolbar from updating the address to the currently viewed page.  It also prevents the field from updating when the displayed page is arrived at by following a clickable link.

This has been repeated on 3 different computers.  The first runs Win2KPro and was recently upgraded from FF2.0.0.18 to FF3.0.4.  The second (this computer) runs WinXPPro and FF3.0.3 which is the originally installed version of FF on this computer.  The third runs OpenSuse 11.0 with FF3.0.3.  All three behave identically as described below.

Scenarios:
1.  Address field is empty.  Click on any link in Fast Dial array.  The selected page is displayed but the address field remains empty.  Following any link on the displayed page does not update the address field display - it remains empty.
2.  Type any address (URL-A) into the nav address field.  The desired page is displayed.  Click on any link in the page.  The new page is displayed, but the address field continues to display URL-A.
3.  Disable Fast Dial add-on and restart FireFox.  The behavior of the address field returns to normal.  Re-enable Fast Dial, restart, and the behavior reverts to that described in scenarios 1 and 2, above.

Reproducible: Always

Steps to Reproduce:
1.  Install Fast Dial add-on.
2.  Try any of the scenarios described in "Details."
Actual Results:  
Address bar does not update with Fast Dial installed AND enabled.

Expected Results:  
Normal display behavior in the address field.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Updated

10 years ago
Component: General → Plugins
Product: Firefox → addons.mozilla.org
Version: 3.0 Branch → unspecified
Resolved invalid because it is an add-on specific bug. Sandboxed version 2.11 (2.9 seemed to be working fine) and mailed the developer (which already provides 2.14 on his site).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.