ASSERTION: node in map twice: crashes on back during reload

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
3 months ago

People

(Reporter: jesup, Assigned: pollmann)

Tracking

({crash})

Trunk
x86
FreeBSD
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Go to www.mozilla.org (my home page).
Go to www.gopconvention.com (ok, it's evil).  
Hit reload.  After a few of the frames have painted, hit back.
First I get the assertions below, and then after I cancel "the plugin loader
plugin isn't loaded" requester, I get a whole bunch of errors and it crashes.
Note: This might be FreeBSD-related.  I also don't have a java installed.

Enabling Quirk StyleSheet
Inside nsPluginHostImpl::FindStoppedPluginForURL...
WEBSHELL+ = 9
Document: Done (5.646 secs)
Error loading URL http://www.gopconvention.com/ 
WARNING: not calling OnDataAvailable, file nsAsyncStreamListener.cpp, line 404
WEBSHELL- = 8
WEBSHELL- = 7
WEBSHELL- = 6
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
###!!! ASSERTION: node in map twice: '(node->mContent != aNode->mContent) ||
((node->mContent == nsnull) && (node->mStyle != aNode->mStyle))', file
nsFrameManager.cpp, line 1907
###!!! Break: at file nsFrameManager.cpp, line 1907
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Document: Done (7.066 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document http://www.mozilla.org/ loaded successfully


...


###!!! ASSERTION: illegal width for combined area: 'aCombinedArea.width >= 0',
file nsLineBox.cpp, line 407
###!!! Break: at file nsLineBox.cpp, line 407
Block(td)(2)@0x8df23b4: line=0x8e3c980 xmost=-559038737
###!!! ASSERTION: Content has no document.: 'doc', file nsTextFrame.cpp, line
4104
###!!! Break: at file nsTextFrame.cpp, line 4104
nsLineLayout: Text(0)@0x8df269c metrics=-559038737,-559038737!
nsLineLayout: Text(0)@0x8df269c didn't set max-element-size!
nsLineLayout: Text(0)@0x8df269c didn't set whad
-559038737,-559038737,-559038737,-559038737!
nsLineLayout: Inline(font)(0)@0x8df2664 metrics=-559038737,315!
nsLineLayout: Inline(font)(0)@0x8df2664 didn't set whad -559038737,315,255,60!
nsLineLayout: Inline(b)(1)@0x8df262c metrics=-559038737,315!
nsLineLayout: Inline(b)(1)@0x8df262c didn't set whad -559038737,315,255,60!
Block(td)(0)@0x8df25e0: line=0x8df2778 xmost=-559037987
###!!! ASSERTION: Content has no document.: 'doc', file nsTextFrame.cpp, line
4104
###!!! Break: at file nsTextFrame.cpp, line 4104
nsLineLayout: Text(0)@0x8df2a48 metrics=-559038737,-559038737!
nsLineLayout: Text(0)@0x8df2a48 didn't set max-element-size!
nsLineLayout: Text(0)@0x8df2a48 didn't set whad
-559038737,-559038737,-559038737,-559038737!
###!!! ASSERTION: illegal width for combined area: 'aCombinedArea.width >= 0',
file nsLineBox.cpp, line 407
###!!! Break: at file nsLineBox.cpp, line 407
Block(td)(0)@0x8df29fc: line=0x8e2988c xmost=-559038737
###!!! ASSERTION: Content has no document.: 'doc', file nsTextFrame.cpp, line
4104
###!!! Break: at file nsTextFrame.cpp, line 4104
nsLineLayout: Text(0)@0x8df2c74 metrics=-559038737,-559038737!
nsLineLayout: Text(0)@0x8df2c74 didn't set max-element-size!
nsLineLayout: Text(0)@0x8df2c74 didn't set whad
-559038737,-559038737,-559038737,-559038737!
###!!! ASSERTION: illegal width for combined area: 'aCombinedArea.width >= 0',
file nsLineBox.cpp, line 407
###!!! Break: at file nsLineBox.cpp, line 407
Block(td)(0)@0x8df2c28: line=0x8e29754 xmost=-559038737
###!!! ASSERTION: Content has no document.: 'doc', file nsTextFrame.cpp, line
4104
###!!! Break: at file nsTextFrame.cpp, line 4104
nsLineLayout: Text(0)@0x8e04094 metrics=-559038737,-559038737!
nsLineLayout: Text(0)@0x8e04094 didn't set max-element-size!
nsLineLayout: Text(0)@0x8e04094 didn't set whad
-559038737,-559038737,-559038737,-559038737!
###!!! ASSERTION: Content has no document.: 'doc', file nsTextFrame.cpp, line
4104
###!!! Break: at file nsTextFrame.cpp, line 4104
nsLineLayout: Text(0)@0x8e04108 metrics=-559038737,-559038737!
nsLineLayout: Text(0)@0x8e04108 didn't set max-element-size!
nsLineLayout: Text(0)@0x8e04108 didn't set whad
-559038737,-559038737,-559038737,-559038737!
nsLineLayout: Inline(b)(1)@0x8e040d0 metrics=-559038737,315!
nsLineLayout: Inline(b)(1)@0x8e040d0 didn't set whad -559038737,315,255,60!
nsLineLayout: Inline(font)(0)@0x8e0405c metrics=-1118076979,240!
Block(td)(0)@0x8e04010: line=0x8e16040 xmost=-1118076979
Segmentation fault - core dumped
(Reporter)

Comment 1

19 years ago
Created attachment 11976 [details]
Backtrace of crash and inspection of some variables
(Reporter)

Comment 2

19 years ago
The backtrace might not be that interesting given it's removed from the original
assertion failures.

The aView object is garbage.
Keywords: crash

Comment 3

19 years ago
wfm under Linux build 2000072408.
(Reporter)

Updated

19 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Doesn't crash on WIN32. Must be Linux or FreeBSD related.

peterson@netscape.com can you try this on a QA linux machine? Thanks :)
(Reporter)

Comment 5

19 years ago
Retested with FreeBSD 20000907xx pull/build
Resolving as WORKSFORME
I no longer see the assertions.  I suspect the crash _may_ have been due to a
problem with fonts that specify a bad X_HEIGHT, which has since been fixed.
(That caused it to think that fonts often were VERY big if there was a
subscript, superscript, etc).
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED

Updated

3 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.