reordering bookmarks on menu triggers ASSERT: copy or move action without a tab

RESOLVED DUPLICATE of bug 465333

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 465333
9 years ago
9 years ago

People

(Reporter: Mark Perris, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081118 Firefox/3.1b1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081118 Firefox/3.1b1pre (.NET CLR 3.5.30729)

When dragging or reordering bookmarks or dividers, the following assert is triggered:

ASSERT: copy or move action without a tab
Stack Trace: 
0:_onDrop([object DragEvent])
1:ondrop([object DragEvent])


Reproducible: Always

Steps to Reproduce:
1. Open bookmarks menu
2. Drag bookmark to new position on bookmarks menu
3. See assert popup
Actual Results:  
ASSERT: copy or move action without a tab
Stack Trace: 
0:_onDrop([object DragEvent])
1:ondrop([object DragEvent])

The move is successful though, and shows when re-opening the menu.


Expected Results:  
No assert.

I wonder if this is related to bug 463385, bug 463386, bug 465179, or bug 225680
(Reporter)

Updated

9 years ago
Component: General → Bookmarks & History
Version: unspecified → Trunk

Comment 1

9 years ago
Happens with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081118 Minefield/3.1b2pre (.NET CLR 3.5.30729) too.

Updated

9 years ago
Blocks: 225680
This sounds like a dup of bug 465333 which was fixed in the 08-11-19 nightly build. Try the latest nightly & see if you can reproduce the problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465333

Comment 4

9 years ago
OK for me with the latest FF3.1b3pre (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081126 Minefield/3.1b3pre)
You need to log in before you can comment on or make changes to this bug.