If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RAM Cache not working in Firefox 3.1 Beta 1 and Pre-beta 2, was working in Firefox 3.0.x

RESOLVED DUPLICATE of bug 454001

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 454001
9 years ago
7 years ago

People

(Reporter: Cliff Hogan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

RAM Cache not working in Firefox 3.1 Beta 1 and Pre-beta 2, was working in Firefox 3.0.x
RAM Cache starts working if Disk cache is disabled.
see also: http://forums.mozillazine.org/viewtopic.php?f=23&t=901895


Reproducible: Always

Steps to Reproduce:
1.Load a page with images.
2.Check about:cache or an extension like Cache Status or Cache Viewer
3.Navigate from the page and click "Back", it confirms that is loading from the disk cache (much slower response than from RAM).



http://forums.mozillazine.org/viewtopic.php?f=23&t=901895

Comment 1

9 years ago
Aha ! Images aren't stored anymore in the memory-cache (see bug 430061), that's why you don't see them anymore. But the cache is still there, it should be added to <about:cache> in bug 60305. Dupe ?

see bug 454001 comment 1 for what the current memory-cache i used for.
(Reporter)

Comment 2

9 years ago
Seems to be a duplicate of 454001, however I believe the old behavior to be better. Maybe limiting the browser.cache.memory.enable to something like 8192 or even 4096 would help mitigate the memory "leak" perception better than not caching images in RAM.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454001
You need to log in before you can comment on or make changes to this bug.