WCAP calendars are not available in lightning/sunbird build 20081118

VERIFIED FIXED in 1.0b1

Status

VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: andreas.treumann, Assigned: dbo)

Tracking

({regression})

Trunk
1.0b1
regression
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
STEPS TO REPRODUCE:
===================

- use lightning/sunbird 20081117 and subscribe to a wcap calendar
- update this profile with the 20081118 build
- restart the application

RESULT:
=======

- the wcap calendar is marked 'not available' in the calendar list
- error at startup in the error console:

Warning: There has been an error reading data for calendar: Andreas Treumann.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80004005. Description: NS_ERROR_FAILURE

Warning: There has been an error reading data for calendar: Andreas Treumann.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: READ_FAILED
EXPECTED RESULT:
================

- the wcap calendar should be available

REPRODUCIBLE:
=============

- always

Regression possible caused by checkin bug 436047.
Flags: blocking-calendar1.0?
(Assignee)

Updated

10 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+
(Assignee)

Comment 1

10 years ago
Created attachment 349178 [details] [diff] [review]
fix - v1
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #349178 - Flags: review?(philipp)
(Assignee)

Updated

10 years ago
Blocks: 465911
Comment on attachment 349178 [details] [diff] [review]
fix - v1

>-            return cal.ical.subcompentIterator(aComponent, compType);
Oops, sorry about that :-}

>     for (let subComp in cal.ical.calendarComponentIterator(icalRootComp, componentType)) {
>-        if (++count > maxResults) {
>-            break;
>-        }
No checking for maxResults anymore?

r=philipp
Attachment #349178 - Flags: review?(philipp) → review+
(Assignee)

Comment 3

10 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/a7ac7311d9e0>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 4

10 years ago
(In reply to comment #2)
> No checking for maxResults anymore?
Sure, maxResults is passed to the server as well as checked when expanding occurrences.
(Reporter)

Comment 5

10 years ago
Checked in lightning and sunbird buils 20081124 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.