Status

Release Engineering
General
--
major
RESOLVED DUPLICATE of bug 471006
10 years ago
5 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We should really have a couple/few machines that are PPC. We've had a few regressions that were PPC only.

See bug 457486 and bug 454878 comment 19.
Component: Release Engineering → Release Engineering: Talos
(Reporter)

Comment 1

10 years ago
And bug 466531, which Tp machines would've likely caught.

Comment 2

10 years ago
We have no PPC machines suitable for this, and no way of getting any since Apple isn't selling them any more.  The effort required to acquire suitable machines and to set up them up seems to outweigh the benefits of having them.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> We have no PPC machines suitable for this, and no way of getting any since
> Apple isn't selling them any more.  The effort required to acquire suitable
> machines and to set up them up seems to outweigh the benefits of having them.

We can certainly find some at Mac resellers. Unopened even. (I know, because I've done it for Camino's tinderboxen.)

What is the effort required? Calling resellers and finding machines to order? We likely already have a few PPC machines and could simply replace those with Intel machines and use them as Talos boxes instead.

The benefits are clear. If we had these machines, we would've caught a new topcrash on a Firefox maintenance branch on checkin instead of scrambling near the end of a tight cycle to determine the problem. I'm not sure how you've determined how the effort outweighs the benefit, but I'd like to hear more reasoning before you consider this WONTFIX.

If PPC is a supported platform, we need to support it.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I understand there is one time you've hit one situation where you needed this, hence filing this bug. 

However, this is really a tradeoff question. We could have similar discussion about different flavors of windows, for example.

It feels to me like the time/effort spent setting this up (buy matching set of PPC macs from gray vendor, find a supported OS+toolchain to run on them, debugging and rolling out talos) is out-of-balance with how many bugs it would catch and with the importance of other work like mobile that would have to be dropped for this. Because of these factors, I feel this is WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> I understand there is one time you've hit one situation where you needed this,
> hence filing this bug. 

There was one instance, yes. But it turns out there's more. I can scour Bugzilla if that'd help. This bug includes at least three instances; there's probably more.

> However, this is really a tradeoff question. We could have similar discussion
> about different flavors of windows, for example.

This isn't about OSes, it's about architectures. We only currently support one architecture for both Windows and Linux: x86. We support two for Mac OS X: PPC and Intel. It's not unreasonable to actually test on an architecture we support and ship to users.

> It feels to me like the time/effort spent setting this up (buy matching set of
> PPC macs from gray vendor, find a supported OS+toolchain to run on them,
> debugging and rolling out talos) is out-of-balance with how many bugs it would
> catch and with the importance of other work like mobile that would have to be
> dropped for this. Because of these factors, I feel this is WONTFIX.

We don't know how many bugs it'd catch, unless you've already run the numbers somehow.

Additionally, we have a supported OS+toolchain: the same one we use on Intel Macs. Rolling out Talos should be the same on either platform. Apple fully supports the same applications and libraries on both 10.4 and 10.5, Intel and PPC.

The barrier here seems to be the setup work (which is certainly not minimal, I'll give you that) and finding machines. Since no one's done work on locating machines, we don't know what the barrier is for that. Also, don't we already have some PPCs as I said in comment 3? I could have sworn some of our build machines were PPC.

I won't reopen this bug again, but it feels like it's not even being considered as an option.
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> There was one instance, yes. But it turns out there's more. I can scour
> Bugzilla if that'd help. This bug includes at least three instances; there's
> probably more.

A quick search yields bug 452698 and bug 462516 in addition to the bugs listed in comment 0 and comment 1.
(Reporter)

Comment 7

10 years ago
(In reply to comment #5)
> I won't reopen this bug again, but it feels like it's not even being considered
> as an option.

I assumed discussion would still happen in this bug despite it being closed. Since that's not the case, I'm going to reopen so my comment 5 can get addressed.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 8

10 years ago
Add a possible bug 469698. Not sure if we have tests for that, but it'd get caught in unit tests if we do.
I believe John and Sam chatted about this - what was the outcome of that?
Sam and I talked about late this last week. A summary is that while we officially support users on PPC macs, in reality, we haven't run full build/unittest/perf infrastructure for PPC macs - at least not in the last 18months, maybe ever? Lets start by figuring out where PPC mac infrastructure fits in with the other mac infrastructure requests.

Closing this bug as a DUP of bug#471006 and moving discussion there.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471006

Updated

9 years ago
Component: Release Engineering: Talos → Release Engineering
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.