Sidebar Search button disabled after show/hide sidebar

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: samir_bugzilla)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000072608 WinNT 4

Steps to Reproduce:
(1) Show My Sidebar (if not already shown)
(2) Switch to the Search tab (if not already the active tab)
(3) Type something in the textfield (e.g. 'test')
(4) Hide My Sidebar (completely, via View | My Sidebar)
(5) Show My Sidebar (via View | My Sidebar, again)

Result:
The Search button is disabled, but it should be enabled since there's still 
text in the textfield.  This likely happens because the button only enabled 
upon keypress in the textfield, and the state of the button doesn't persist 
between hide/show sidebar (why is that, if the text of the textfield 
persists?), so it doesn't know to enable upon reopening the sidebar.  A simple 
check upon loading the Search tab to see if there's text in the textfield (and 
then enabling the button accordingly) would fix this, but I'm not sure if the 
load function for the active tab is called again when the sidebar is hidden and 
then shown.
Netscape nav triage team: as per Matt Fisher's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-

Updated

18 years ago
Target Milestone: --- → Future

Comment 2

18 years ago
Marking nsbeta1- bugs as future to get off the radar.
(Reporter)

Comment 3

17 years ago
reassigning matt's old bugs to default owner.
Assignee: matt → sgehani

Comment 4

16 years ago
Tested in 2002080508.
Seems to be fixed now.
works fine for me, 2002082308, win98.
marking WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.