System Tray : new Message is shown

RESOLVED INVALID

Status

Thunderbird
General
--
minor
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: lapsus63, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5pre) Gecko/2008111205 GranParadiso/3.0.5pre
Build Identifier: version 2.0.0.18 (20081105)

I'm using Thunderbird with the application "trayit" (http://www.trayit.com) which allows me to reduce the application into the system tray (windows XP).

So, I should only see the main frame from there. But after a while, I can see a second frame listed as reduced : Compose new message, with no subject. 
When I click onto, I can see the border of a frame showing only the title (in french : Redaction - Pas de sujet - Unicode UTF 8 (Composing, no subject, utf8).
Once shown, the frame is visible from Windows task bar, but not listed while composing Alt-Tab.
I'm sure it is not a bug from the external application trayit, because this bug appears only with Thunderbird.
To hide the window I have to kill thunderbird.
Thanks.

Reproducible: Always

Steps to Reproduce:
1. Launch TB
2. Use it for a while ; reduce to systray with application trayit
3. Right-Clic on the systray'ed icon, you have two frames accessible (Thunderbird and a new composing message)
4. Clic on the "new composing"
Actual Results:  
A frame no painted appears (just the border), and I can't hide nor close it. I have to kill TB.

Expected Results:  
The second frame should not be visible with trayit at the systray.
The second frame is most likely a cached window that we use (but hide/remove from the display) to improve the display time of the compose window.

The fact that we are (presumably) hiding it correctly, e.g. not appearing on windows task bar, and systray isn't implies that this isn't our bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.