If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Address Book should not be in tasks menu/component bar if not installed

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

17 years ago
Build ID: 2000072608 WinNT 4

Steps to Reproduce:
(1) Download an installer build
(2) Choose Custom installation option, and don't install anything except the 
browser

Address Book still appears in the Task menu and the component bar, but clicking 
either does nothing (as it's not installed, since MailNews didn't get 
installed).

Is this a MailNews issue or an Installer issue?

Comment 1

17 years ago
mailnews.  resetting component.
Assignee: ssu → putterman
Component: Installer → Address Book
Product: Browser → MailNews
QA Contact: gbush → lchiang
Target Milestone: --- → M17

Comment 2

17 years ago
QA assignee to nbaca for looking at all menus in this case. I'd assume things
like Search Mail, New Msg and possibly some other things would need to be
disabled or removed, too.
QA Contact: lchiang → nbaca
(Assignee)

Comment 3

17 years ago
Mail-related items are properly removed from the global File | New > submenu, 
but Search Mail and Search Addressbook still appear in the browser search menu 
(albeit disabled...I don't recall now if this is intentional, or if they just 
haven't yet been enabled)

Comment 4

17 years ago
moving to future milestone.
Target Milestone: M17 → Future
(Assignee)

Comment 5

17 years ago
Somewhat disagree with the Future marking on this.  Bug 32347 (which might fix 
this, but I'm doubtful) was marked nsbeta3+ because of "unpredicatable 
behavior if you click on the icon when the app isn't installed".  This is 
exactly that case....
Keywords: nsbeta3

Updated

17 years ago
Keywords: mail4

Comment 6

17 years ago
+ per mail triage
Whiteboard: [nsbeta3+]
Target Milestone: Future → M18

Comment 7

17 years ago
second pass: - per mail triage
Keywords: relnoteRTM
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/28]

Comment 8

17 years ago
Sorry for the extra mail. Removing mail4 keyword.
Keywords: mail4
This is just cosmetic, right?

Gerv
Whiteboard: [nsbeta3-][cut 8/28] → [nsbeta3-][cut 8/28] relnote-user

Comment 10

17 years ago
I'm not in agreement that this warrants a mention in release notes. Removing
keyword/whiteboard nomination
Keywords: relnoteRTM
Whiteboard: [nsbeta3-][cut 8/28] relnote-user → [nsbeta3-][cut 8/28]

Comment 11

17 years ago
reassigning to racham.
Assignee: putterman → racham
Keywords: mail3

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 12

17 years ago
Created attachment 21229 [details] [diff] [review]
patch to show account summary

Comment 13

17 years ago
Created attachment 21230 [details]
snapshot#1 - mail account

Comment 14

17 years ago
Created attachment 21231 [details]
snapshot#2 - news account

Comment 15

17 years ago

**** IGNORE ATTACHMENTS (#21229, #21230, #21231) JUST POSTED BY ME. THEY BELONG
TO BUG 46450. SORRY ABOUT THAT. *****

Comment 16

17 years ago
marking nsbeta1-
Keywords: nsbeta3 → nsbeta1-
Whiteboard: [nsbeta3-][cut 8/28]

Updated

17 years ago
Target Milestone: M18 → ---

Updated

17 years ago
Keywords: nsCatFood

Comment 17

17 years ago
Three of the buttons are in comm/content/communicator/tasksOverlay.xul 
these are Navigator, Composer, and Addressbook.

The mail Button is in messenger/content/messenger/mailTasksOverlay.xul

Since mailTasksOverlay.xul isn't installed if messenger isn't installed, the
mail button dosen't appear on the taskbar.

To prevent the Address Book from appearing on installs without the mail client,
move the code for mini-addr from tasksOverlay.xul to mailTasksOverlay.xul

Comment 18

17 years ago
*** Bug 58913 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Changing OS/Platform to All, because I see this on Ja MacOS 9.1 using 
06-07-11-0.9.1
OS: Windows NT → All
Hardware: PC → All
*** Bug 83327 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
This bug also affects Linux rpm (installing only mozilla rpm without
mozilla-mail rpm) does display non working AddressBook meny entry..

Comment 22

16 years ago
I'm sorry to say that I attached attachment 41186 [details] [diff] [review] to the duplicate bug 89234 :-(

Comment 23

16 years ago
*** Bug 89234 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
Just in case it was not completely clear, attachment 41186 [details] [diff] [review] from
neil@parkwaycc.co.uk is a proposed fix.

Comment 25

16 years ago
Created attachment 42559 [details] [diff] [review]
Patch that can actually be applied

Comment 26

16 years ago
Patch looks good to me... that only took 361 days... I'm not authorized to r
though, let's get an r/sr quick, I'm so incredibly sick of this bug.
Target Milestone: --- → mozilla0.9.3

Comment 27

16 years ago
Neil's patch looks good to me; r=hwaara.

Comment 28

16 years ago
r=bhuvan

Comment 29

16 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Comment 30

16 years ago
Reassigning to me, I'll check it in tonight.
Assignee: racham → blake
Status: ASSIGNED → NEW

Comment 31

16 years ago
checked in. sorry about the timestamp, i only noticed this bugmail a few mins 
ago and didn't think much about it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 32

16 years ago
Build 2001-08-13-03: WinMe
Build 2001-08-13-08: Mac 9.04, Linux RH 6.2
Verified Fixed. After installing just Navigator, the Address Book menu item does
not appear in the Tasks menu and does not appear as a component in the taskbar. 

Mail/News also does not appear.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.