Crash durning browsing with X Window System error

RESOLVED DUPLICATE of bug 463503

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 463503
10 years ago
10 years ago

People

(Reporter: t.moravec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

Durning browsing i had got several firefox crashes with this error. My operating system is a Kbuntu Linux 8.10 Intrepid with KDE 4.1.3.

QPixmap: Invalid pixmap parameters
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 538141 error_code 182 request_code 156 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7ed9858]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb7ed9a1e]
#2 /usr/lib/libX11.so.6 [0xb69d3619]
#3 /usr/lib/libXrender.so.1(XRenderFreePicture+0x41) [0xb6a84f41]
#4 /usr/lib/libQtGui.so.4 [0xb4a446bf]
#5 /usr/lib/libQtGui.so.4 [0xb4a4517d]
#6 /usr/lib/libQtGui.so.4(_ZN7QPixmap5derefEv+0x5d) [0xb4a399ad]
#7 /usr/lib/libQtGui.so.4(_ZN7QPixmapD2Ev+0x30) [0xb4a39e10]
#8 /usr/lib/libQtGui.so.4 [0xb4a3f0ba]
#9 /usr/lib/libQtGui.so.4 [0xb4a3f72f]
#10 /usr/lib/libQtGui.so.4 [0xb4a3ed5a]
#11 /lib/tls/i686/cmov/libc.so.6(exit+0x89) [0xb7c68d69]
#12 /usr/lib/libgdk-x11-2.0.so.0 [0xb658a6b7]
#13 /usr/lib/libbonoboui-2.so.0 [0xb61bdd15]
#14 /usr/lib/libX11.so.6(_XError+0x109) [0xb69cbef9]
#15 /usr/lib/libX11.so.6 [0xb69d3fe8]
#16 /usr/lib/libX11.so.6(_XReply+0x15a) [0xb69d439a]
#17 /usr/lib/libX11.so.6(XGetGeometry+0x6d) [0xb69afa6d]
#18 /usr/lib/libgdk-x11-2.0.so.0(gdk_pixmap_foreign_new_for_display+0xba) [0xb658b54a]
#19 /usr/lib/libgdk-x11-2.0.so.0(gdk_pixmap_foreign_new+0x1a) [0xb658b5aa]
firefox: xcb_xlib.c:73: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463503
You need to log in before you can comment on or make changes to this bug.