Warning message in Apple Console about deprecated class/API

VERIFIED DUPLICATE of bug 402635

Status

--
minor
VERIFIED DUPLICATE of bug 402635
10 years ago
10 years ago

People

(Reporter: corinnepallen, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (like Firefox/2.0.0.18)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.18) Gecko/20081112 Camino/1.6.5 (like Firefox/2.0.0.18)

The following message shows up in my Apple console frequently:
11/20/08 12:21:23 PM Camino[159] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz. 

This site mentions the deprecation:
http://developer.apple.com/documentation/Cocoa/Reference/ApplicationKit/Classes/NSQuickDrawView_Class/Reference/Reference.html

And refers developers to this site for more info:
http://developer.apple.com/documentation/Carbon/Conceptual/QuickDrawToQuartz2D/index.html#//apple_ref/doc/uid/TP40001098


I have been having some strange random logout behaviors on my OS X 10.5.5 macbook, which may or may not be related, but I am checking all mysterious items in the console...

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Severity: normal → minor

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402635

Comment 2

10 years ago
Yeah, whatever you're seeing is totally unrelated to this, for the record.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.