Crash when quitting mailnews

VERIFIED DUPLICATE of bug 46390

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 46390
18 years ago
18 years ago

People

(Reporter: scottputterman, Assigned: Ray Whitmer)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I crash every time I quit when using mailnews.  On the commerical build the 
talkback report has no stack.  But on my debug build I get:

nsStringDeallocator::operator()(void * 0x0012f794) line 2062 + 28 bytes
nsDeque::ForEach(nsDequeFunctor & {...}) line 346 + 14 bytes
nsStringRecycler::~nsStringRecycler() line 2080
$E2() + 13 bytes
_CRT_INIT(void * 0x10000000, unsigned long 0, void * 0x00000001) line 236
_DllMainCRTStartup(void * 0x10000000, unsigned long 0, void * 0x00000001) line 
289 + 17 bytes
NTDLL! 77f69dca()
KERNEL32! 77f19ffb()
doexit(int 0, int 0, int 0) line 392
exit(int 0) line 279 + 13 bytes
mainCRTStartup() line 345
KE
(Reporter)

Comment 1

18 years ago
nominating for beta2.
Keywords: nsbeta2
(Assignee)

Comment 2

18 years ago
This looks like a duplicate of 46360, and probably of the one no one could
duplicate the other day after lots of trying.
(Reporter)

Comment 3

18 years ago
it's possible. but 46360 seems to be for a leak and a leak shouldn't cause a 
crash. as for reproduceability, I can reproduce every single time I quit with 
both my mozilla debug and  Netsape commerical builds.
(Reporter)

Comment 4

18 years ago
just do mozilla -mail and quit.  You may have to load a folder (my Inbox gets 
loaded by default). It's probably something we're doing in mailnews but I'm not 
sure the best way to track this down.  It crashes when trying to delete the 
string which makes me believe it's been deleted already.
(Assignee)

Comment 5

18 years ago
Sorry, I meant bug 46390.
(Reporter)

Comment 6

18 years ago
yes, its' a dup. I'll mark it that way and nominate that one.

*** This bug has been marked as a duplicate of 46390 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
marking Verified as a dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.