date range queries stopped working

VERIFIED FIXED

Status

Socorro
General
--
major
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: dbaron, Assigned: ozten)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Sometime in the past day or two, date range queries on http://crash-stats.mozilla.com stopped working.

Steps to reproduce (variant 1):
 1. load http://crash-stats.mozilla.com/
 2. choose Product: Firefox
 3. choose Branch: 1.9.1
 4. choose Version: Firefox 3.1b2pre
 5. Change the "2" in "Date range" to "4"
 6. Change the "weeks" in Date range to "hours"
 7. hit Submit query

Steps to reproduce (variant 2):
 1. load http://crash-stats.mozilla.com/?do_query=1&product=Firefox&version=Firefox%3A3.1b2pre&query_search=signature&query_type=contains&query=&date=&range_value=4&range_unit=hours

Expected results:  Page showing "Query Results ... Results within 4 hours of now, and ...", and showing a few dozen crashes for the top crash.

Actual results: Page showing "Query Results ... Results within 2 weeks of now, and ..." and showing a few thousand crashes for the top crash.
(Reporter)

Comment 1

9 years ago
(Actually, I'm pretty sure I last looked at this last night, which would make this a regression between then and now.)

Comment 2

9 years ago
bug 466059
(Reporter)

Comment 3

9 years ago
You're saying you think that's what caused the regression?  Or that the second patch on that bug fixes this regression which was caused by the first patch?
(Reporter)

Comment 4

9 years ago
Looks like it's fixed now.

Comment 5

9 years ago
yes hours works now, but "Occurring before date" still fails.

for example, setting date to 2008-10-16 00:00:00 and specifying 2 weeks (including changing specs to a single version) results in message

Warning: Your search was not specific enough. Please note we actually searched for:
Results within 2 weeks of 2008-11-08, where the crash signature is exactly 'nsTreeSelection::GetSingle(int*)', and the product is one of Thunderbird, and the version is one of Thunderbird:3.0a1, Thunderbird:3.0a1pre, Thunderbird:3.0a2, Thunderbird:3.0a2pre, Thunderbird:3.0b1pre.
Blocks: 466059
(Assignee)

Comment 6

9 years ago
This is my bad, I mis-understood the date fields relationship to date range. Will remove validation from this field, since date range is the only field which needs to be validated.
Assignee: nobody → aking
(Assignee)

Comment 7

9 years ago
Created attachment 349755 [details] [diff] [review]
Updated tests and code to not constrain the date input
Attachment #349755 - Flags: review?(morgamic)

Comment 8

9 years ago
fails still. Example: 
Thunderbird
3.0b1pre
date 2008-11-08 00:00:00
period 1 week

http://crash-stats.mozilla.com/?do_query=1&product=Thunderbird&version=Thunderbird%3A3.0b1pre&query_search=signature&query_type=contains&query=&date=2008-11-08+00%3A00%3A00&range_value=1&range_unit=weeks

Query Results - crash dates range from 11-18 to 11-12, and it gives the message...

Warning: Your search was not specific enough. Please note we actually searched for:
Results within 1 weeks of 2008-11-18, and the product is one of Thunderbird, and the version is one of Thunderbird:3.0b1pre.
Attachment #349755 - Flags: review?(morgamic) → review+
(Assignee)

Comment 9

9 years ago
Submitted an IT Request for push to prod.
Status: NEW → ASSIGNED

Comment 10

9 years ago
(In reply to comment #9)
> Submitted an IT Request for push to prod.

this is still wrong.

pick thunderbird, 3.0b2pre, exactly "nsParseMailMessageState::Release", occurring before 2009-01-07, 5 days

results in 

Your search was not specific enough. Please note we actually searched for:
Results within 5 days of 2009-01-20, where the crash signature is exactly 'nsParseMailMessageState::Release', and the product is one of Thunderbird, and the version is one of Thunderbird:3.0b2pre.
It looks like that the given date is replaced by another one. No idea what so special on Jan, 20th.
(Assignee)

Comment 12

9 years ago
It appears that the webapp-php has been reverted to a revision before this was fixed. I will follow up with IT.

Note: MTBF and Top Crashers By URL are missing also.
(Assignee)

Comment 13

9 years ago
IT has svn up to r772. Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Thanks. Looks good.
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.