Crash when pressing space followed by backspace in text area

VERIFIED DUPLICATE of bug 46629

Status

()

Core
Layout: Form Controls
P3
major
VERIFIED DUPLICATE of bug 46629
18 years ago
18 years ago

People

(Reporter: Cristian Seres, Assigned: rubydoo123)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [fi] (WinNT; U)
BuildID:    2000072608

Mozilla crashes if space and backspace are pressed at the end of the line 
followed by two empty lines.

Reproducible: Always
Steps to Reproduce:
1. Activate text input
2. Type some text, one character is enough
3. Press enter two times
6. Go to the end of the first line
7. Press spacebar
8. Press backspace

Actual Results:  An access violation (Mozilla.exe)							

Expected Results:  Mozilla should have deleted the space at the end of the first 
line.							

A simple form to reproduce the bug:

<FORM NAME="form1" METHOD="post" ACTION="nothing">

<TEXTAREA NAME="message" COLS=50 ROWS=12></TEXTAREA>
</FORM>

Comment 1

18 years ago
I just tried this with a cvs build (Thu Jul 27 06:28:12 CDT 2000) and could not
reproduce it. Fixed?

Comment 2

18 years ago
I can confirm this under Linux with Build ID 2000072521. Can someone please
check with latest nightly builds?

Comment 3

18 years ago
Confirmed on Linux Build 2000072621 (M18) and also 2000072521 (M17).  I can
reproduce with only one newline, not two as the original reporter stated.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 4

18 years ago
grabbing it
Assignee: rods → beppe
(Assignee)

Comment 5

18 years ago
marking as dup of 46629

*** This bug has been marked as a duplicate of 46629 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Looks fixed on Linux 2000072709 (M18).




(Reporter)

Comment 7

18 years ago
No, there is still something weard happening. I have got build 2000072721
(Linux). Try same steps as before, but strike spacebar (step 7) many times. The
text jumps at the end of the line when backspace is pressed. Also try moving
with the cursor after this: there are "dead" areas where you can not move the
cursor.
Severity: critical → major
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 8

18 years ago
please don't reopen dups -- go to the parent bug 46629 and make your comments -- 
remarking as dup.

*** This bug has been marked as a duplicate of 46629 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Marking VERIFIED DUPLICATE on:
- LinuxRH62 2000-09-13-08-M18 Commercial
- Win98     2000-09-13-08-M18 Mozilla
- MacOS86   2000-09-13-04-M18 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.