Firefox keeps uploaded file open forever

RESOLVED DUPLICATE of bug 183689

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 183689
10 years ago
10 years ago

People

(Reporter: Stanislav Malyshev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729) FirePHP/0.2.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729) FirePHP/0.2.1

When I upload a file using a form with input type="file", Firefox keeps this file open forever on local computer, preventing me from deleting or modifying it until I restart Firefox.

Reproducible: Always

Steps to Reproduce:
1. Create simple form with file upload. 
2. use the form to upload a file
3. run Process Explorer from sysinternals
4. Inspect firefox.exe's open files, see uploaded file there being open
Actual Results:  
File is kept open forever

Expected Results:  
File should be closed as soon as upload was done

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
You need to log in before you can comment on or make changes to this bug.