mp3 begins but quits after a second or two

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
major
VERIFIED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Clay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Embedded mp3 begins but quits shortly after beginning.  Works in Safari but not Firefox.

Reproducible: Always

Steps to Reproduce:
1.click mp3 link

Actual Results:  
It plays for two seconds and quits

Expected Results:  
Should play full mp3.  It does play in Safari and IE, but not in Firefox

Comment 1

10 years ago
mp3 files are played by a plugin, so we need to determine which plugin and what version you have to know what the problem is.
Please put about:plugins into the addressbar, enter. Then copy all the contents of that page into a comment here.
Also, you may have better luck next time contacting support from links at
http://tinyurl.com/firefoxhelp
before filing a bug.

Comment 2

10 years ago
Resolving this as incomplete until there is a response to comment 1.
Clay, also let us know if installing Flash 10 fixes this:
http://get.adobe.com/flashplayer/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

10 years ago
Installed plugins
Find more information about browser plugins at mozilla.org.
Help for installing plugins is available from plugindoc.mozdev.org.
Java Embedding Plugin 0.9.6.4

    File name: MRJPlugin.plugin
    Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Embedded JVM 	xjv 	Yes
application/x-java-applet 	Embedded Java Applet 	xja 	Yes
application/x-java-applet;version=1.1 	Embedded Java Applet 	xja11 	Yes
application/x-java-applet;version=1.1.1 	Embedded Java Applet 	xja111 	Yes
application/x-java-applet;version=1.1.2 	Embedded Java Applet 	xja112 	
RE: COMMENT 1:

Yes
application/x-java-applet;version=1.1.3 	Embedded Java Applet 	xja113 	Yes
application/x-java-applet;version=1.2 	Embedded Java Applet 	xja12 	Yes
application/x-java-applet;version=1.2.1 	Embedded Java Applet 	xja121 	Yes
application/x-java-applet;version=1.2.2 	Embedded Java Applet 	xja122 	Yes
application/x-java-applet;version=1.3 	Embedded Java Applet 	xja13 	Yes
application/x-java-applet;version=1.3.1 	Embedded Java Applet 	xja131 	Yes
application/x-java-applet;version=1.4 	Embedded Java Applet 	xja14 	Yes
application/x-java-applet;version=1.4.1 	Embedded Java Applet 	xja141 	Yes
application/x-java-applet;version=1.4.2 	Embedded Java Applet 	xja142 	Yes
application/x-java-applet;version=1.5 	Embedded Java Applet 	xja15 	Yes
Default Plug-in

    File name: Default Plugin.plugin
    Netscape Navigator Default Plug-in

MIME Type 	Description 	Suffixes 	Enabled
* 	All types 	* 	No
MoveNetworks Quantum Media Player

    File name: Move-Media-Player.plugin
    npmnqmp 07103007

MIME Type 	Description 	Suffixes 	Enabled
application/x-vnd.movenetworks.qm 	MoveNetworks Move Media Player Plug-In 	qmx 	Yes
application/x-vnd.moveplay1.qm 	MoveNetworks Move Media Player Plug-In 	qmx 	Yes
Shockwave Flash

    File name: Flash Player.plugin
    Shockwave Flash 10.0 r12

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Shockwave Flash 	swf 	Yes
application/futuresplash 	FutureSplash Player 	spl 	Yes
QuickTime Plug-in 7.5.5

    File name: QuickTime Plugin.plugin
    The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes 	Enabled
application/sdp 	SDP stream descriptor 	sdp 	Yes
application/x-sdp 	SDP stream descriptor 	sdp 	Yes
application/x-rtsp 	RTSP stream descriptor 	rtsp,rts 	Yes
video/quicktime 	QuickTime Movie 	mov,qt,mqv 	Yes
video/x-msvideo 	Video For Windows 	avi,vfw 	Yes
video/msvideo 	Video For Windows 	avi,vfw 	Yes
video/avi 	Video For Windows 	avi,vfw 	Yes
video/flc 	AutoDesk Animator 	flc,fli,cel 	Yes
audio/x-wav 	WAVE audio 	wav,bwf 	Yes
audio/wav 	WAVE audio 	wav,bwf 	Yes
audio/aiff 	AIFF audio 	aiff,aif,aifc,cdda 	Yes
audio/x-aiff 	AIFF audio 	aiff,aif,aifc,cdda 	Yes
audio/basic 	uLaw/AU audio 	au,snd,ulw 	Yes
audio/mid 	MIDI 	mid,midi,smf,kar 	Yes
audio/x-midi 	MIDI 	mid,midi,smf,kar 	Yes
audio/midi 	MIDI 	mid,midi,smf,kar 	Yes
audio/vnd.qcelp 	QUALCOMM PureVoice audio 	qcp 	Yes
audio/x-gsm 	GSM audio 	gsm 	Yes
audio/AMR 	AMR audio 	AMR 	Yes
audio/aac 	AAC audio 	aac,adts 	Yes
audio/x-aac 	AAC audio 	aac,adts 	Yes
audio/x-caf 	CAF audio 	caf 	Yes
audio/vnd.qcelp 	QUALCOMM PureVoice audio 	qcp 	Yes
audio/ac3 	AC3 audio 	ac3 	Yes
audio/x-ac3 	AC3 audio 	ac3 	Yes
video/x-mpeg 	MPEG media 	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa 	Yes
video/mpeg 	MPEG media 	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa 	Yes
audio/mpeg 	MPEG audio 	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a 	Yes
audio/x-mpeg 	MPEG audio 	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a 	Yes
video/3gpp 	3GPP media 	3gp,3gpp 	Yes
audio/3gpp 	3GPP media 	3gp,3gpp 	Yes
video/3gpp2 	3GPP2 media 	3g2,3gp2 	Yes
audio/3gpp2 	3GPP2 media 	3g2,3gp2 	Yes
video/sd-video 	SD video 	sdv 	Yes
application/x-mpeg 	AMC media 	amc 	Yes
video/mp4 	MPEG-4 media 	mp4 	Yes
audio/mp4 	MPEG-4 media 	mp4 	Yes
audio/x-m4a 	AAC audio 	m4a 	Yes
audio/x-m4p 	AAC audio 	m4p 	Yes
audio/x-m4b 	AAC audio book 	m4b 	Yes
video/x-m4v 	Video 	m4v 	Yes
audio/mpeg 	MP3 audio 	mp3,swa 	Yes
audio/x-mpeg 	MP3 audio 	mp3,swa 	Yes
audio/mp3 	MP3 audio 	mp3,swa 	Yes
audio/x-mp3 	MP3 audio 	mp3,swa 	Yes
audio/mpeg3 	MP3 audio 	mp3,swa 	Yes
audio/x-mpeg3 	MP3 audio 	mp3,swa 	Yes
image/x-bmp 	BMP image 	bmp,dib 	Yes
image/x-macpaint 	MacPaint image 	pntg,pnt,mac 	Yes
image/pict 	PICT image 	pict,pic,pct 	Yes
image/x-pict 	PICT image 	pict,pic,pct 	Yes
image/png 	PNG image 	png 	Yes
image/x-png 	PNG image 	png 	Yes
image/x-quicktime 	QuickTime image 	qtif,qti 	Yes
image/x-sgi 	SGI image 	sgi,rgb 	Yes
image/x-targa 	TGA image 	targa,tga 	Yes
image/tiff 	TIFF image 	tif,tiff 	Yes
image/x-tiff 	TIFF image 	tif,tiff 	Yes
image/jp2 	JPEG2000 image 	jp2 	Yes
image/jpeg2000 	JPEG2000 image 	jp2 	Yes
image/jpeg2000-image 	JPEG2000 image 	jp2 	Yes
image/x-jpeg2000-image 	JPEG2000 image 	jp2 	Yes
Flip4Mac Windows Media Plugin 2.2.1

    File name: Flip4Mac WMV Plugin.plugin
    The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.

MIME Type 	Description 	Suffixes 	Enabled
application/x-mplayer2 	Windows Media Plugin 		Yes
video/x-ms-asf-plugin 	Windows Media Plugin 		Yes
application/asx 	Windows Media Plugin 		Yes
video/x-ms-asf 	Windows Media Video 	asf 	Yes
video/x-ms-asx 	Windows Media Playlist 	asx 	Yes
video/x-ms-wmv 	Windows Media Video 	wmv 	Yes
video/x-ms-wvx 	Windows Media Playlist 	wvx 	Yes
audio/x-ms-wma 	Windows Media Audio 	wma 	Yes
audio/x-ms-wax 	Windows Media Playlist 	wax 	Yes
video/x-ms-wm 	Windows Media Video 	wm 	Yes
video/x-ms-wmp 	Windows Media Video 	wmp 	Yes
video/x-ms-wmx 	Windows Media Playlist 	wmx 	Yes
Silverlight Plug-In

    File name: Silverlight.plugin
    2.0.30523.9

MIME Type 	Description 	Suffixes 	Enabled
application/x-silverlight 	Microsoft Silverlight 	xaml 	Yes
application/x-silverlight-2-b2 	Microsoft Silverlight 	xaml 	Yes
DivX Web Player

    File name: DivXBrowserPlugin.plugin
    DivX Web Player version 1.4.0.233

MIME Type 	Description 	Suffixes 	Enabled
video/divx 	DivX Video File 	divx,div 	Yes



RE: COMMENT 2
Installed Flash 10, but it did not resolve the problem.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 4

10 years ago
I am having the same issue with certain URLS when playing an embed mp3. Such as mysite.com/123.mp3

I can tell you that it does it on certain sites and not others. I can forward URLS if needed.

George

Comment 5

9 years ago
My web host has done this now, so I'm motivated to give it some publicity. The support forums are full of this problem.

For some admins who install mod_deflate, they do not omit mp3 from the conf. This causes FF3/QT plugin to play the mp3 for a few seconds and stop. This is the fault of the clueless server admin, but IE plays it fine this way, identifying and handling the compression.

Is there some interest in changing this behavior to avoid the problem, even if mp3s are sent compressed? 

http://michaelsmusicservice.com/music/Lang.Meditation.html contains an MP3 from a server that stupidly sends MP3s with compression.

Cheers! Michael
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago8 years ago
Resolution: --- → INCOMPLETE

Comment 8

8 years ago
Confirmed, fixed in recent QT plugins.

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.