WINNT 5.2 mozilla-central nightly % Is Burning

RESOLVED FIXED

Status

Release Engineering
General
P2
normal
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: WildcatRay, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081122 Minefield/3.1b2pre Firefox/3.0.4
Build Identifier: 

WINNT 5.2 mozilla-central nightly % is burning. If I understand things correctly, the Trunk (Firefox 3.1b2pre or Minefield nightlies are built here and thus will not be available until it is fixed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

9 years ago
Slave was moz2-win32-slave, error was:
link -NOLOGO -DLL -OUT:xul.dll -PDB:xul.pdb -SUBSYSTEM:WINDOWS  dlldeps-xul.obj nsStaticXULComponents.obj nsDllMain.obj dlldeps.obj nsGFXDeps.obj dlldeps-zlib.obj nsUnicharUtils.obj nsCompressedCharMap.obj nsBidiUtils.obj nsRDFResource.obj    ./module.res -NXCOMPAT -SAFESEH -DYNAMICBASE -MANIFEST:NO  -DEBUG -OPT:REF -OPT:nowin98 -LTCG:PGINSTRUMENT    ../../toolkit/xre/xulapp_s.lib  ../../staticlib/components/xpconnect.lib ../../staticlib/components/necko.lib ../../staticlib/components/uconv.lib ../../staticlib/components/i18n.lib ../../staticlib/components/chardet.lib ../../staticlib/components/jar50.lib ../../staticlib/components/pref.lib ../../staticlib/components/caps.lib ../../staticlib/components/htmlpars.lib ../../staticlib/components/imglib2.lib ../../staticlib/components/gklayout.lib ../../staticlib/components/docshell.lib ../../staticlib/components/embedcomponents.lib ../../staticlib/components/webbrwsr.lib ../../staticlib/components/nsappshell.lib ../../staticlib/components/txmgr.lib ../../staticlib/components/chrome.lib ../../staticlib/components/commandlines.lib ../../staticlib/components/toolkitcomps.lib ../../staticlib/components/pipboot.lib ../../staticlib/components/pipnss.lib ../../staticlib/components/gkplugin.lib ../../staticlib/components/mozfind.lib ../../staticlib/components/appcomps.lib ../../staticlib/components/xpinstall.lib ../../staticlib/components/jsd.lib ../../staticlib/components/autoconfig.lib ../../staticlib/components/auth.lib ../../staticlib/components/cookie.lib ../../staticlib/components/permissions.lib ../../staticlib/components/universalchardet.lib ../../staticlib/components/composer.lib ../../staticlib/components/rdf.lib ../../staticlib/components/windowds.lib ../../staticlib/components/intlapp.lib ../../staticlib/components/storagecomps.lib ../../staticlib/components/places.lib ../../staticlib/components/tkautocomplete.lib ../../staticlib/components/satchel.lib ../../staticlib/components/pippki.lib ../../staticlib/components/ucvmath.lib ../../staticlib/components/imgicon.lib ../../staticlib/components/gkgfxthebes.lib ../../staticlib/components/gkwidget.lib ../../staticlib/components/oji.lib ../../staticlib/components/accessibility.lib ../../staticlib/components/spellchecker.lib ../../staticlib/components/zipwriter.lib ../../staticlib/xpcom_core.lib ../../staticlib/ucvutil_s.lib ../../staticlib/gkgfx.lib ../../staticlib/gfxshared_s.lib ../../staticlib/mozreg_s.lib ../../staticlib/morkreader_s.lib ../../staticlib/thebes.lib ../../staticlib/jsj.lib   ../../dist/lib/sqlite3.lib    ../../jpeg/jpeg3250.lib ../../modules/libimg/png/png.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/mozlcms.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/js3250.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/crmf.lib         e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/smime3.lib         e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/ssl3.lib         e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/nss3.lib         e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/nssutil3.lib         e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/softokn3.lib ../../gfx/cairo/cairo/src/mozcairo.lib ../../gfx/cairo/libpixman/src/mozlibpixman.lib  ../../modules/zlib/src/mozz.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/nspr4.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/plc4.lib e:/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/dist/lib/plds4.lib   shell32.lib ole32.lib uuid.lib version.lib winspool.lib comdlg32.lib imm32.lib winmm.lib wsock32.lib msimg32.lib kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib  usp10.lib oleaut32.lib   
   Creating library xul.lib and object xul.exp
Generating code
e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\xpconnect\src\xpcwrappedjsclass.cpp(300) : warning C4700: uninitialized local variable 'jsexception' used
Finished generating code
NEXT ERROR PGOCVT : fatal error PG0081: Unable to open file 'xul.pgd' for reading.
xul.pgd : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt
make[5]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox/toolkit/library'
make[5]: *** [xul.dll] Error 99
make[4]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox'
make[4]: *** [libs_tier_toolkit] Error 2
make[3]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox'
make[3]: *** [tier_toolkit] Error 2
make[2]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-nightly/build/obj-firefox'
make[2]: *** [default] Error 2
make[1]: Leaving directory `/e/builds/moz2_slave/mozilla-central-win32-nightly/build'
make[1]: *** [build] Error 2
make: *** [profiledbuild] Error 2
program finished with exit code 2

Full log:
http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox&errorparser=unix&logfile=1227434400.1227439493.19422.gz&buildtime=1227434400&buildname=WINNT%205.2%20mozilla-central%20nightly&fulltext=1
Assignee: server-ops → nthomas
Status: UNCONFIRMED → ASSIGNED
Component: Server Operations: Tinderbox Maintenance → Release Engineering: Maintenance
Ever confirmed: true
Priority: -- → P2
QA Contact: mrz → release
(Assignee)

Comment 2

9 years ago
Going to treat this as a transient error until we find otherwise. Cleaned up moz2-win32-slave15 and triggered a new nightly build.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Saw this again today - it looks like it's caused by running out of disk space.
(Reporter)

Comment 4

9 years ago
First, thanks for fixing things yesterday.

Second, saw this again today (20081124), but the build completed and is now available. It was explained to me that "burning" while building (yellow) is the result of a prior crash and that the "burning" indicator does not change until there is a successful build. If that is so, then that would seem to be what happened today.

Updated

9 years ago
Component: Release Engineering: Maintenance → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.