"Search messages" is in the wrong menu.

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: ws.bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [driver: WONTFIX?])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0a3

When I want to _find_ a _message_, it's quite natural to go to the "Message" menu and expect a "Find" item in there.

Instead, the "Search messages" is in the "Edit" menu.

This is wrong because I am not trying to edit anything at all, so the /last/ menu I check is the "Edit" menu.

Thinking about it, every single other menu is more appropriate, including File, View, Go, Message and Tools - they would all make some amount of sense if they hosted the "Find message" menu. But not "Edit".

Reproducible: Always

Steps to Reproduce:
N/A
ask to drivers.
Whiteboard: [driver: WONTFIX?]
The message menu has items that are supposed to act on a selected message or multiple selected messages.  So search isn't really appropriate in the message menu as it would only search that message.

The current location was likely chosen because the windows HIG recommends Edit -> Find / Search as the proper location for that type of action.  Of course we have both find and search which do very different things so it does seem like a gray area.

For such a useful item the search really is buried in the menus, however the new gloda search will be much more prominent and works a lot better.  I'm sorry, what you're saying makes sense, but I don't think we can make this change happen.
(Reporter)

Comment 3

9 years ago
No problem, I have indeed observed that Edit / Find is very common. Widespread convention vs. something that makes more sense... Tough choice :)

Looking forward to an altogether better search UI in TB3...
Thanks for the report and understanding the issue!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 5

9 years ago
I see classifying Search as a User tool, and as such it residing in the Tools Menu.  

An alternative was considered too.  Since Tb is an E-mail client with many features unique to it's class of Apps, that a new top level menu be added to house all of its searching functions.

Updated

9 years ago
Duplicate of this bug: 294045
You need to log in before you can comment on or make changes to this bug.