remove mail.showFolderPaneColumns prefs (since expanded columns is no longer supported)

RESOLVED FIXED in Thunderbird 3.0b2

Status

Thunderbird
Preferences
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

Trunk
Thunderbird 3.0b2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 349796 [details] [diff] [review]
proposed fix

Following bug 414038 thunderbird doesn't have the ability to show folder pane columns anymore. 

Doesn't look like they're coming back (see bug 414038) so we should remove the UI for it too...
Attachment #349796 - Flags: review?(jminta)
(Assignee)

Comment 1

10 years ago
Meant to reference bug 464973.

Comment 2

10 years ago
Comment on attachment 349796 [details] [diff] [review]
proposed fix

Should wait until after b1 to land, because of the string changes.
Attachment #349796 - Flags: review?(jminta) → review+
(In reply to comment #2)
> (From update of attachment 349796 [details] [diff] [review])
> Should wait until after b1 to land, because of the string changes.

Although given the visibility of this pref and the lack of functionality, maybe it would be better to land the patch without the string changes, and then just remove the strings post b1.
Duplicate of this bug: 466619
(Assignee)

Comment 5

10 years ago
Might be good yes. I won't get to land it today - so with code freeze coming up, someone should feel free to land the non-string parts for me.
I've pushed the non-string parts today: https://bugzilla.mozilla.org/show_bug.cgi?id=466519

We can push the string part when we reopen the tree for beta 2.

Comment 7

10 years ago
Is the problem that it's not (easily) possible to implement those columns with current code or that Thunderbird doesn't want those colunms any more? I'm just asking because SeaMonkey probably wants to adopt the JS-driven folder pane stuff but definitely wants to keep those columns as an option.
See comment 1.
(In reply to comment #7)
Bug 465564 & Bug 465568 exist for new way to display unread_count/mail_count/size.
(moving to single column style from previous multi column style)
  Bug 465564 : for unread/mail_count display
  Bug 465568 : for folder size display
(Assignee)

Comment 10

10 years ago
String changes landed, too.

changeset:   1377:6099218b5df6
http://hg.mozilla.org/comm-central/rev/6099218b5df6

->FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.