Closed Bug 466533 Opened 11 years ago Closed 4 years ago

Web page errors shouldn't be able to push chrome errors from the error console / separate chrome and web content errors

Categories

(Toolkit Graveyard :: Error Console, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1260877

People

(Reporter: aryx, Unassigned)

References

(Depends on 1 open bug)

Details

Web page errors shouldn't be able to push chrome errors from the error console / separate chrome and web content errors.

Explanation: Especially if set javascript.options.strict=true and javascript.options.showInConsole=true, you can get valuable information for debugging, but unfortunately web content floods the error console. So maybe saving the web and the chrome errors separately would be a good idea.
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 1260877
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.