js/tests/ecma_3/Date/15.9.4.3.js expects wrong values from getUTCDate

VERIFIED DUPLICATE of bug 466269

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 466269
10 years ago
10 years ago

People

(Reporter: jimb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
SpiderMonkey evaluates the following expression:

new Date(Date.UTC(2006, 0, -Infinity)).getUTCDate())

to yield NaN, which seems to be what ECMA-262 requires.  However, js/tests/ecma_3_Date/15.9.4.3.js expects this to be 31.  There are other similar errors.

As part of bug 461180, the code in js/tests/shell.js which compares expected and actual test results will be fixed to compare NaNs correctly, which will make these tests begin to fail.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466269

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.