bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

onClick=submit() does not submit values when used with type=radio

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Joakim Recht, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test5 i686; en-US; m17) Gecko/20000725
BuildID:    2000072508

A form is not submitted properly when using radio buttons with a
onClick=document.form.submit(). The action part of the form seems to be
activated alright, but the value of the radio button is not received on the
target page.

Reproducible: Always
Steps to Reproduce:
1.Enter above page (in Danish, but the form is at the buttom)
2.Hit one of the radio buttons


Actual Results:  Page reloads, but the buttons are still available, and nothing
has been registered in the database (it's a simple poll, when you have voted,
the results of the poll should be shown).

Expected Results:  Another table with the poll results should be shown. This
happens if the variable $stemme, which the radio buttons should have set, is
received on the target page.

Comment 1

18 years ago
Confirming this on 2000080113 on Linux RH 6.2
(Assignee)

Comment 2

18 years ago
Could you attach a reduced testcase for testing?

Comment 3

18 years ago
WFM on linux 2000080308/0108(M18). Existed in 2000073009(M18). Resolving as FIXED.
If anyone can reproduce using a newer build then 0308, feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 5

17 years ago
Verified build 20010730T OS:Linux7.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.