Theme switching doesn't work when quitting SeaMonkey from the Dock

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: john, Unassigned)

Tracking

Trunk
PowerPC
macOS
Bug Flags:
blocking-seamonkey2.0a3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081124 SeaMonkey/2.0a2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081124 SeaMonkey/2.0a2pre

Once you select your new theme that will be applied when you restart seamonkey, you must quit seamonkey by clicking "Seamonkey" on the top bar then selecting "Quit Seamonkey." If you go down to the dock, right-click on the logo and select "quit," when you restart it the theme will not be applied.

Reproducible: Always

Steps to Reproduce:
1.select new theme
2.Quit Seamonkey by going down the Dock, right-clicking (or ctrl+click), and selecting "Quit"
3.Restart Seamonkey
Actual Results:  
does not change theme

Expected Results:  
should change theme

Comment 1

10 years ago
I've seen this too. In my debug build, I often see this assertion when quitting from the Dock:

2008-11-25 21.02.21 [0x0-0x4c04c].org.mozilla.seamonkey[9877] WARNING: nsAppShell::Exit() called redundantly: file /Users/Stefan/comm/mozilla/widget/src/cocoa/nsAppShell.mm, line 708

I wonder if we crash silently here?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2.0a3?
Summary: Theme Switching Issues on OSX → Theme switching doesn't work when quitting SeaMonkey from the Dock

Updated

10 years ago
Version: unspecified → Trunk

Comment 2

10 years ago
Actually, now I'm unable to reproduce the issue

Comment 3

10 years ago
John, does this happens all the time? I know this have been hitting me for some time ago, but now I can't seem to reproduce it (at least not with my debug build). I see the warning in the console though, so that might be unrelated to this.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> John, does this happens all the time? I know this have been hitting me for some
> time ago, but now I can't seem to reproduce it (at least not with my debug
> build). I see the warning in the console though, so that might be unrelated to
> this.

The opposite thing happens to me. I see no console error but the theme doesn't change when i restart

Comment 5

10 years ago
You don't have a debug build, so it's natural that you don't see the warning. But does this happens all the time, is the problem 100% reproducible?

Comment 6

10 years ago
OK, so it turns out that I can reproduce this - but not in my self-compiled debug build. It's easily reproducible in a official nightly, I just tried Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081126 SeaMonkey/2.0a2pre (most recent nightly).

Comment 7

10 years ago
It appears that it seems to work if you switch theme from the add-on manager:

1) Tools --> Add-on Manager
2) Select themes tab, select the theme
3) Click "Use theme"
4) Ignore the restart button, just quit SeaMonkey from the Dock
5) Launch SeaMonkey

Updated

10 years ago
Duplicate of this bug: 459591

Comment 9

10 years ago
So, I made a non-debug build in order to see if I could reproduce this in my environment. I used the following options in my .mozconfig:

ac_add_options --enable-application=suite
ac_add_options --disable-debug
ac_add_options --disable-optimize
ac_add_options --disable-tests

It's surely not the same options as the official builds, but anyway. Then I packaged the bundle ('make' in objdir/suite/installer) in a .dmg and mounted the disk image, copied the .app to my desktop and launched it. But I can't reproduce the problem. So, this looks like a problem with either the config options or the fact that the official nightlies are produced on a machine running Tiger.
In reply to comment #9:

The options used to build any build (including an official build) can be seen in the page which comes up when you type about:buildconfig in the URL bar (then hit Enter).

IIUC, one noticeable difference between nightly builds and yours is that nightlies are built with --enable-optimize. (There might be other differences.)

Comment 11

10 years ago
Yeah, I know... fwiw, I tried to build with the 10.4u.sdk, but that didn't made any difference (still wfm).
Using this nightly of 2008-12-16 <http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2008-12-16-00-comm-central/>, this is WFM on Tiger.

Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20081216 SeaMonkey/2.0a3pre

Comment 13

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081217 SeaMonkey/2.0a3pre

This is odd. For some reason it works fine for me now. Using the most recent nightly, when I switch theme and then quit SeaMonkey from the Dock it works.

John, would you mind trying the latest trunk build and see if it works for you?

Comment 14

10 years ago
Not blocking 2a3 on this
Flags: blocking-seamonkey2.0a3? → blocking-seamonkey2.0a3-

Comment 15

10 years ago
I'm resolving this as wfm based on: comment #12, comment #13, the fact that I can't reproduce the issue on a recent nightly and no since there's no further response from the reporter.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.