Primitive number not wrapped when used as paramter of apply

RESOLVED FIXED

Status

defect
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mguillemot, Unassigned)

Tracking

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111317 Ubuntu/8.04 (hardy) Firefox/3.0.4
Build Identifier: 

In interpreted mode, primitive numbers are stored in the dblStack and should be wrapped when they are used as parameters of the apply method

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reporter

Comment 1

11 years ago
The problem is just a verification for UniqueTag.DOUBLE_MARK that is missing.

Comment 2

11 years ago
Committed patch to both HEAD and Rhino1_7R2_BRANCH.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Reporter

Comment 3

11 years ago
Hannes, thanks for quickly applying this patch.
You need to log in before you can comment on or make changes to this bug.