"ASSERTION: Bad race happening" (nsSpeculativeScriptThread::StartParsing)

VERIFIED FIXED in mozilla1.9.1b3

Status

()

defect
P1
normal
VERIFIED FIXED
11 years ago
7 years ago

People

(Reporter: jruderman, Assigned: mrbkap)

Tracking

({assertion, verified1.9.1})

Trunk
mozilla1.9.1b3
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

11 years ago
About 25% of the time, loading http://www.runnersworld.com/ triggers:

###!!! ASSERTION: Bad race happening: '!mCurrentlyParsing', file /Users/jruderman/central/parser/htmlparser/src/nsParser.cpp, line 411
That sounds bad
Flags: blocking1.9.1?
Assignee: nobody → mrbkap
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b3
Posted patch FixSplinter Review
The problem is that we were starting two speculative parsers that were then racing against each other. I'm assuming that we were near EOF when they were created, since otherwise, we probably would have crashed.

With this patch, the parser will only block itself once per recursive invocation.
Attachment #351288 - Flags: superreview?(jst)
Attachment #351288 - Flags: review?(jst)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #351288 - Flags: superreview?(jst)
Attachment #351288 - Flags: superreview+
Attachment #351288 - Flags: review?(jst)
Attachment #351288 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/582e9452bc01
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Reporter

Updated

11 years ago
Keywords: testcase-wanted
verified FIXED using the url provided by Jesse on debug builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090706 Shiretoko/3.5.1pre ID:20090706143721

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090706 Minefield/3.6a1pre ID:20090706143743
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.