If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Assertion in Forget-word-frame

RESOLVED DUPLICATE of bug 56155

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 56155
18 years ago
17 years ago

People

(Reporter: jesup, Assigned: joki (gone))

Tracking

({testcase})

Trunk
x86
FreeBSD
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Load this page, see assertion.  I've added a backtrace and a bunch of data from
state variables.

Might be related to the font error issues in bug 44677 (bad sizes for fonts)
(Reporter)

Comment 1

18 years ago
Created attachment 12022 [details]
backtrace of assertion, data from all relevant objects/etc
(Reporter)

Comment 2

18 years ago
###!!! ASSERTION: forget-word-frame: '(void*)aFrame == mWordFrames[0]', file
nsLineLayout.cpp, line 2779
###!!! Break: at file nsLineLayout.cpp, line 2779
I get
Document http://gamecenter.com/News/Item/0,3,0-4530,00.html?st.gc.sg.gn loaded 
successfully
in WinNT4 20000818. FreeBSD only?

Looks like the FreeBSD port has a few problems. Who is looking after it?

Gerv
(Reporter)

Comment 4

17 years ago
FreeBSD 4.0 pull/build 8/30/00
Fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

17 years ago
I just ran into this again.  FreeBSD 4.1 20001009xx

I get 4 of these assertions at
http://messages.yahoo.com/?action=q&board=WGAT

Backtrace to be attached.  Since this page changes often, I'll try to grab it as
well.

Changed URL, but note that that page changes often.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 6

17 years ago
Created attachment 16646 [details]
backtrace at yahoo
(Reporter)

Comment 7

17 years ago
Created attachment 16647 [details]
HTML for that URL (at messages.yahoo.com)
(Reporter)

Comment 8

17 years ago
The testcase works.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 9

17 years ago
Giving 5 of clayton's bugs to joki for triaging.
Assignee: clayton → joki

Comment 10

17 years ago
See also bug 56073

*** This bug has been marked as a duplicate of 56155 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.