Body borders are not displayed correctly when I use floated elements there.

RESOLVED DUPLICATE of bug 437230

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 437230
9 years ago
9 years ago

People

(Reporter: Mahdi H, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

It seems that floated elements don't affect the body borders and the borders render as if there's no floated elements, so that if you set border for BODY, floated elements may be rendered outside of the border.

Reproducible: Always

Steps to Reproduce:
1.create a "div" with style: "float:left" and height more than entire body
2.give "body" some border style, like: "border:solid 5px #00F;
3.see the result!

Actual Results:  
border ignores floated elements. like this: http://img03.picoodle.com/img/img03/3/11/26/f_withbugm_fda599e.png

Expected Results:  
border should wrap floated elements too. like this: http://img32.picoodle.com/img/img32/3/11/26/f_withoutbugm_a9dbc82.png

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Layout: Floats
Product: Firefox → Core
QA Contact: general → layout.floats
Resolution: --- → DUPLICATE
Duplicate of bug: 437230
You need to log in before you can comment on or make changes to this bug.