Don't require a comment on Resolved DUPLICATE but do require for all other resolution types.

RESOLVED DUPLICATE of bug 463453

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED DUPLICATE of bug 463453
10 years ago
10 years ago

People

(Reporter: Eiren Smith, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-us) AppleWebKit/525.26.2 (KHTML, like Gecko) Version/3.2 Safari/525.26.12
Build Identifier: 3.2RC2

Don't require a comment on Resolved DUPLICATE but do require for all other resolution types.



Reproducible: Always

Steps to Reproduce:
1. Set 3.2RC2 so it requires a comment when Resolving a bug.
2. Try to Resolve a bug as DUPLICATE without adding your own comment.
Actual Results:  
3. Observe that Bugzilla tells you you must enter a comment.

Expected Results:  
I expected to not be required to enter a comment in this case, especially since Bugzilla adds a comment about the duplicate condition for me automatically anyway.

I don't have our old (2.18 or 3.0 or 3.0.5) Bz installed to see how this used to be. However, this was a surprise today when I tried to Resolve a bug as DUPLICATE. I THINK this used to work differently. I THINK I used to be able to Resolve DUPLICATE without a comment when commentonresolve was TRUE.

If I'm wrong and this was never possible, this is just an enhancement request for an option to make this possible. If I'm right and this used to be possible, it's kind of a regression (to me.)

Comment 1

10 years ago
(In reply to comment #0)
> If I'm wrong and this was never possible, this is just an enhancement request
> for an option to make this possible. If I'm right and this used to be possible,
> it's kind of a regression (to me.)

We don't want to differentiate the DUPLICATE resolution from other resolutions, as discussed in bug 463453. Required comments are now controlled by the status workflow. What will happen in the future (probably Bugzilla 3.4) is the removal of the commentonduplicate parameter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463453
You need to log in before you can comment on or make changes to this bug.