Closed Bug 466925 Opened 13 years ago Closed 13 years ago

'M' keyboard shortcut for "mark as unread" no longer works in standalone open message window

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: justdave, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081124 Shredder/3.0b1pre

Hitting the "M" key to mark a message as unread again stopped working recently.  It's still listed in the Message > Mark As > menu as the shortcut, but it doesn't work.  (This is while viewing the message itself in a separate window - it still works fine in the mailbox summary listing).  The 'N' shortcut for next message and 'S' to add a star still work fine.
I see this too. Taking, as I suspect I might have caused it...
Assignee: nobody → mkmelin+mozilla
OS: Mac OS X → All
Hardware: PC → All
Blocks: 462681
Fix for mark read and star mark.

For SelectedMessagesAreDeleted it's different, and I do get an exception. Still have to investigate that. I think the backend returns an error when it's not necessary.
Attachment #350378 - Flags: review?(jminta)
Comment on attachment 350378 [details] [diff] [review]
proposed fix (for mark read and star mark)

Isn't the correct fix to make the standalone viewer's gDBView return 1 for numSelected?

Are we assured that hdrForFirstSelectedMessage will never be null?
David: what do you think? Should gDBView.numSelected return 1 in the standalone msg window?
Magnus, I guess it could - a view doesn't really know that it's in a stand-alone msg window, other than the tree selection is null, and m_currentlyDisplayedMsgKey is not nsMsgKey_None (or m_currentlyDisplayedViewIndex is not -1, perhaps). As long as that can't happen in the 3-pane ui, then we're probably ok making nsMsgDBView do that.
Thanks for the pointers! This patch makes setting read/starred/deleted work, except for in saved searches. 
(also removes an unused variable ‘firstIdInThread’)

gDBView.hdrForFirstSelectedMessage doesn't work for saved searches, and I don't know how to fix that.

An error occurred updating the cmd_delete command; =[Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBView.hdrForFirstSelectedMessage]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/mailWindowOverlay.js :: SelectedMessagesAreDeleted :: line 726"  data: no]
Attachment #350378 - Attachment is obsolete: true
Attachment #350573 - Flags: superreview?(bienvenu)
Attachment #350573 - Flags: review?(bienvenu)
Attachment #350378 - Flags: review?(jminta)
I'm trying to get to this, but other things keep getting pushed onto the stack :-(
star shortcut fails 3.0b1 20081204, as does M. also fails using mouse click via context menu.  R and P, work  

there is a workaround of course, via thread pane. We may be OK not having this for b1 -  - many people use standalone message, but I doubt many people have mark message as read at something other than 0 (like me).  But those who do may take this as a serious usability regression.

in short, I don't have a good read on user impact.
Summary: 'M' keyboard shortcut for "mark as unread" no longer works in an open message window → 'M' keyboard shortcut for "mark as unread" no longer works in standalone open message window
I'm one of those folks who use the standalone message window exclusively, and have the preview pane completely disabled.  It's definitely a usability issue.  The (mostly) usable workaround is to close the window and mark it from the thread pane of course.  The problem with this is if you've been using "N" or space to go to the next message several times, the selection in the thread pane doesn't move to follow the message in the active window, so the one you've been looking at won't be selected when you close it, and then it's a guessing game which one you were looking at if you didn't pay attention to which one un-bolded itself last.
Target Milestone: --- → Thunderbird 3.0b2
Attachment #350573 - Flags: superreview?(bienvenu)
Attachment #350573 - Flags: superreview+
Attachment #350573 - Flags: review?(bienvenu)
Attachment #350573 - Flags: review+
Comment on attachment 350573 [details] [diff] [review]
proposed fix, v2 (make gDBView.numSelected = 1 in standalone)

thx Magnus. Can you file a follow on bug for the saved search case and assign it to me? I think that's a general problem with saved searches.
I've checked this in - changeset:   1461:b145e4360b31. Marking fixed. thx for the patch. We'll deal with the saved search case in a follow on bug, which I'll file if Magnus doesn't beat me to it.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 470513
You need to log in before you can comment on or make changes to this bug.