Any search cannot be saved, pressing "remember search" results in "The page cannot be displayed "

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Alex Poretski, Unassigned)

Tracking

3.0.6
Other
Linux

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: Bugzilla version 3.0.6

Pressing "Remember search" on the search result page follows to URL

https://bugzilla.mycompany.com/bugtest/buglist.cgi?newquery=bug_file_loc%3D%26bug_file_loc_type%3Dallwordssubstr%26bug_id%3D%26bug_status%3DNEW%26bug_status%3DASSIGNED%26bug_status%3DREOPENED%26bugidtype%3Dinclude%26chfieldfrom%3D%26chfieldto%3DNow%26chfieldvalue%3D%26deadlinefrom%3D%26deadlineto%3D%26email1%3D%26email2%3D%26emailassigned_to1%3D1%26emailassigned_to2%3D1%26emailcc2%3D1%26emailreporter2%3D1%26emailtype1%3Dsubstring%26emailtype2%3Dsubstring%26field-1-0-0%3Dbug_status%26field-1-1-0%3Dshort_desc%26field0-0-0%3Dnoop%26long_desc%3D%26long_desc_type%3Dsubstring%26query_format%3Dadvanced%26remaction%3D%26short_desc%3Da%26short_desc_type%3Dallwordssubstr%26type-1-0-0%3Danyexact%26type-1-1-0%3Dallwordssubstr%26type0-0-0%3Dnoop%26value-1-0-0%3DNEW%252CASSIGNED%252CREOPENED%26value-1-1-0%3Da%26value0-0-0%3D&cmdtype=doit&remtype=asnamed&newqueryname=new

And the browser shows "The page cannot be displayed" 

Reproducible: Always

Steps to Reproduce:
1. On the query.cgi page enter some search text and press Search
2. On the buglist.cgi search result enter any name in Remember search field
3. Press Remember search

Actual Results:  
The page cannot be displayed 

Expected Results:  
Search is saved and appears under Saved searches

real company name in the URL replaced by "mycompany"

Comment 1

9 years ago
Most likely, you have file permissions incorrectly set. I cannot reproduce using Bugzilla 3.0.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0.6
(Reporter)

Comment 2

9 years ago
Well, I found the true reason. File permissions were set correctly, the URL above was just rejected by ISA HTTP filter.
The only question that remains is why buglist.cgi generates ampersands in this specific query as "%3D" and not as "&" (like in other queries). But this is not for discussion here of course.

Merci Frédéric!
You need to log in before you can comment on or make changes to this bug.