Crash logging into geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel)

VERIFIED FIXED

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: jesup, Assigned: Dan M)

Tracking

({crash, topcrash, verifyme})

Trunk
x86
FreeBSD
crash, topcrash, verifyme

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

18 years ago
(checkout/build 7/27/00)
While trying to track down a spammer, mozilla crashed when I went to the
spammer's page (which had a javascript error) and was redirected to the
geocities home page.  Note that channel/aDocChannel is nsnull until we get to
nsDocLoaderImpl::DocLoaderIsEmpty.

This does not happen if I go directly to the site.  It appears to be related to
handling the redirect.  Probably related to bug 46410.

The crash may be related to the assertion failures.

This bug is repeatable.

Error loading URL http://209.1.224.17/hamlin483/ 
JavaScript error: 
http://209.1.224.17/hamlin483/ line 13: yfEA is not defined


Breakpoint 2, nsDebug::Assertion (aStr=0x28da3ef5 "Channel list is not empty.", 
    aExpr=0x28da3eea "count == 0", aFile=0x28da3be5 "nsLoadGroup.cpp",
aLine=239)
    at nsDebug.cpp:184
184        InitLog();
Current language:  auto; currently c++
(gdb) c
Continuing.
###!!! ASSERTION: Channel list is not empty.: 'count == 0', file
nsLoadGroup.cpp, line 239
###!!! Break: at file nsLoadGroup.cpp, line 239

Breakpoint 2, nsDebug::Assertion (aStr=0x28da3f26 "Foreground URLs are active.", 
    aExpr=0x28da3f10 "mForegroundCount == 0", aFile=0x28da3be5
"nsLoadGroup.cpp", 
    aLine=240) at nsDebug.cpp:184
184        InitLog();
(gdb) c
Continuing.
###!!! ASSERTION: Foreground URLs are active.: 'mForegroundCount == 0', file
nsLoadGroup.cpp, line 240
###!!! Break: at file nsLoadGroup.cpp, line 240
WARNING: not calling OnDataAvailable, file nsAsyncStreamListener.cpp, line 403
Enabling Quirk StyleSheet
BrowserViewSource(); 
 *** Current document charset: charset=ISO-8859-1
WEBSHELL+ = 5
WEBSHELL+ = 6
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Setting content window
*** SetDocumentCharset(ISO-8859-1)
Error loading URL about:blank 
Enabling Quirk StyleSheet
Document http://209.1.224.17/hamlin483/ loaded successfully
Enabling Quirk StyleSheet

Program received signal SIGSEGV, Segmentation fault.
0x29aa446e in ?? ()
(gdb) 

#0  0x29aa446e in nsWalletlibService::OnEndDocumentLoad (this=0x81f28c0, 
    aLoader=0x8988d00, channel=0x0, aStatus=0) at nsWalletService.cpp:331
#1  0x28ea8f7c in nsDocLoaderImpl::FireOnEndDocumentLoad (this=0x815af00, 
    aLoadInitiator=0x8988d00, aDocChannel=0x0, aStatus=0) at nsDocLoader.cpp:810
#2  0x28ea8f9c in nsDocLoaderImpl::FireOnEndDocumentLoad (this=0x8250200, 
    aLoadInitiator=0x8988d00, aDocChannel=0x0, aStatus=0) at nsDocLoader.cpp:817
#3  0x28ea8f9c in nsDocLoaderImpl::FireOnEndDocumentLoad (this=0x8988d00, 
    aLoadInitiator=0x8988d00, aDocChannel=0x0, aStatus=0) at nsDocLoader.cpp:817
#4  0x28ea8902 in nsDocLoaderImpl::DocLoaderIsEmpty (this=0x8988d00, aStatus=0)
    at nsDocLoader.cpp:615
#5  0x28ea8709 in nsDocLoaderImpl::OnStopRequest (this=0x8988d00, 
    aChannel=0x8f3e200, aCtxt=0x0, aStatus=0, aMsg=0x281d3664)
    at nsDocLoader.cpp:544
#6  0x28cf45d6 in nsLoadGroup::RemoveChannel (this=0x8983f00, channel=0x8f3e200, 
    ctxt=0x0, aStatus=0, aStatusArg=0x281d3664) at nsLoadGroup.cpp:545
#7  0x28d3f091 in nsHTTPChannel::ResponseCompleted (this=0x8f3e200, 
    aListener=0x8f11f80, aStatus=0, aStatusArg=0x281d3664)
    at nsHTTPChannel.cpp:1790
#8  0x28d49c43 in nsHTTPServerListener::OnStopRequest (this=0x8995e80, 
    channel=0x8eb3404, i_pContext=0x8f3e200, i_Status=0, aStatusArg=0x281d3664)
    at nsHTTPResponseListener.cpp:719
#9  0x28cdad50 in nsOnStopRequestEvent::HandleEvent (this=0x8997600)
    at nsAsyncStreamListener.cpp:301
#10 0x28cda271 in nsStreamListenerEvent::HandlePLEvent (aEvent=0x8e94aa0)
    at nsAsyncStreamListener.cpp:97
#11 0x2817ebc1 in PL_HandleEvent (self=0x8e94aa0) at plevent.c:587
#12 0x2817ea50 in PL_ProcessPendingEvents (self=0x8155d40) at plevent.c:528
#13 0x281809ae in nsEventQueueImpl::ProcessPendingEvents (this=0x8155d00)
    at nsEventQueue.cpp:356
#14 0x28978223 in event_processor_callback (data=0x8155d00, source=11, 
    condition=GDK_INPUT_READ) at nsAppShell.cpp:158
#15 0x28977e25 in our_gdk_io_invoke (source=0x82ab180, condition=G_IO_IN, 
    data=0x82ab170) at nsAppShell.cpp:58
#16 0x28b325aa in g_io_unix_dispatch () from /usr/local/lib/libglib12.so.3
#17 0x28b33d17 in g_main_dispatch () from /usr/local/lib/libglib12.so.3
#18 0x28b3431f in g_main_iterate () from /usr/local/lib/libglib12.so.3
#19 0x28b344a1 in g_main_run () from /usr/local/lib/libglib12.so.3
#20 0x28a686f3 in gtk_main () from /usr/X11R6/lib/libgtk12.so.2
#21 0x28978995 in nsAppShell::Run (this=0x81370b0) at nsAppShell.cpp:335
#22 0x2849679e in ?? ()
   from
/home/jesup/src/mozilla_work/mozilla/dist/bin/components/libnsappshell.so
#23 0x80533c8 in main1 (argc=1, argv=0xbfbfd33c, nativeApp=0x0)
    at nsAppRunner.cpp:913
#24 0x8053b21 in main (argc=1, argv=0xbfbfd33c) at nsAppRunner.cpp:1093
(gdb) p channel
$1 = (nsIChannel *) 0x0
(gdb) (gdb) p docChannel
$11 = {
  mRawPtr = 0x0
}
(gdb) p mDocumentChannel
$12 = {
  mRawPtr = 0x0
}
(gdb) p mLoadGroup
$13 = {
  mRawPtr = 0x8983f00
}
(gdb) p *this
$14 = {
  <nsIDocumentLoader> = {
    <nsISupports> = {
      _vptr$ = 0x28ec6000
    }, <No data fields>}, 
  <nsIStreamObserver> = {
    <nsISupports> = {
      _vptr$ = 0x28ec5fe0
    }, <No data fields>}, 
  <nsSupportsWeakReference> = {
    <nsISupportsWeakReference> = {
      <nsISupports> = {
        _vptr$ = 0x28ec5fc0
      }, <No data fields>}, 
    members of nsSupportsWeakReference: 
    mProxy = 0x896dc70
  }, 
  <nsIProgressEventSink> = {
    <nsISupports> = {
      _vptr$ = 0x28ec5fa0
    }, <No data fields>}, 
  <nsIWebProgress> = {
    <nsISupports> = {
      _vptr$ = 0x28ec5f60
    }, <No data fields>}, 
  <nsIInterfaceRequestor> = {
    <nsISupports> = {
      _vptr$ = 0x28ec5f38
    }, <No data fields>}, 
  members of nsDocLoaderImpl: 
  mRefCnt = 41, 
  _mOwningThread = 0x8072200, 
  mDocumentChannel = {
    mRawPtr = 0x0
  }, 
  mDocObservers = {
    mImpl = 0x8986840, 
    _vptr$ = 0x281f6b00
  }, 
  mListenerList = {
    mImpl = 0x8986820, 
    _vptr$ = 0x281f6b00
  }, 
  mContainer = 0x896870c, 
  mParent = 0x8250200, 
  mCommand = {
    <basic_nsAWritableString<char>> = {
      <basic_nsAReadableString<char>> = {
        _vptr$ = 0x281f5c80
      }, <No data fields>}, 
    <nsStr> = {
      mLength = 0, 
      mCapacity = 0, 
      mCharSize = eOneByte, 
      mOwnsBuffer = 0, 
      {
        mStr = 0x281d3664 "", 
        mUStr = 0x281d3664
      }
    }, <No data fields>}, 
  mIsLoadingDocument = 0, 
  mLoadGroup = {
    mRawPtr = 0x8983f00
  }, 
  mChildList = {
    mRawPtr = 0x8983f80
  }, 
  mProgressListener =  {
   mRawPtr = 0x0
  }, 
  mProgressStateFlags = 16, 
  mCurrentSelfProgress = 37184, 
  mMaxSelfProgress = 37184, 
  mCurrentTotalProgress = 37184, 
  mMaxTotalProgress = 37184, 
  mChannelInfoList = {
    mImpl = 0x8f36b00, 
    _vptr$ = 0x281f6b00
  }
}
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
my stack trace on  Talkback win32 trunk M18 Mozilla build looks the same.
Tested with NT.
http://climate/reports/incidenttemplate.cfm?bbid=14890976http://climate/reports/incidenttemplate.cfm?bbid=14890976

over to wallet, we crash in code lasat touched by danm
 
Assignee: danm
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
made it on to the topcrash radar this morning..

looks xp, with some additional URL that folks are seeing this on
http://www.linuxtoday.com  and http://www.novell.com

haven't checked out if those are reproducable.


nsWalletlibService::OnEndDocumentLoad
Stack Trace: 
nsWalletlibService::OnEndDocumentLoad()
nsDocLoaderImpl::FireOnEndDocumentLoad()
nsDocLoaderImpl::FireOnEndDocumentLoad()
nsDocLoaderImpl::FireOnEndDocumentLoad()
nsDocLoaderImpl::DocLoaderIsEmpty()
nsDocLoaderImpl::OnStopRequest()
nsLoadGroup::RemoveChannel()
nsHTTPChannel::ResponseCompleted()
nsHTTPServerListener::OnStopRequest()
nsOnStopRequestEvent::HandleEvent()
nsStreamListenerEvent::HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xee3a (0x4077ae3a)
libglib-1.2.so.0 + 0x10673 (0x4077c673)
libglib-1.2.so.0 + 0x10cab (0x4077ccab)
libglib-1.2.so.0 + 0x10e61 (0x4077ce61)
libgtk-1.2.so.0 + 0x92beb (0x4069abeb)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x18313 (0x40253313)

    nsWalletlibService::OnEndDocumentLoad 4aa8e759
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072109 CrashDate: 2000-07-23 UptimeMinutes: 64  Total: 99 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14665611

    nsWalletlibService::OnEndDocumentLoad 4c5970fc
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072109 CrashDate: 2000-07-24 UptimeMinutes: 26  Total: 211 
        OS: Windows 95  4.0 build 67109975
        URL: www.linuxtoday.com
        Comment: Waiting for the main page to load.
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14745776

    nsWalletlibService::OnEndDocumentLoad 92350bf6
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072705 CrashDate: 2000-07-27 UptimeMinutes: 4  Total: 4 
        OS: Windows NT  4.0 build 1381
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14882959

    nsWalletlibService::OnEndDocumentLoad d0535246
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072609 CrashDate: 2000-07-27 UptimeMinutes: 73  Total: 165 
        OS: Windows 98  4.10 build 67766446
        URL: www.novell.com
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14885634

    nsWalletlibService::OnEndDocumentLoad 46729fb3
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072709 CrashDate: 2000-07-27 UptimeMinutes: 3  Total: 3 
        OS: Windows NT  4.0 build 1381
        URL: http://209.1.224.17/hamlin483/
        Comment: bug 46699
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14890976

    nsWalletlibService::OnEndDocumentLoad f9bc5135
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072709 CrashDate: 2000-07-28 UptimeMinutes: 111  Total: 111 
        OS: Windows 98  4.10 build 67766222
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14935721

    nsWalletlibService::OnEndDocumentLoad 4cab5730
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072812 CrashDate: 2000-07-28 UptimeMinutes: 4  Total: 4 
        OS: Windows 98  4.10 build 67766446
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14947346

    nsWalletlibService::OnEndDocumentLoad 4cab5730
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072812 CrashDate: 2000-07-28 UptimeMinutes: 1  Total: 5 
        OS: Windows 98  4.10 build 67766446
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14947351

    nsWalletlibService::OnEndDocumentLoad 4cab5730
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072812 CrashDate: 2000-07-28 UptimeMinutes: 1  Total: 6 
        OS: Windows 98  4.10 build 67766446
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14947427

    nsWalletlibService::OnEndDocumentLoad 4cab5730
        
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/extensions/wallet/src/nsWall
etService.cpp line 332
        Build: 2000072812 CrashDate: 2000-07-28 UptimeMinutes: 4  Total: 20 
        OS: Windows 98  4.10 build 67766446
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=14948109

    nsWalletlibService::OnEndDocumentLoad() ce6bbf5c
         line 
        Build: 2000072920 CrashDate: 2000-07-30 UptimeMinutes: 21  Total: 22 
        OS: Linux 2.2.15
        URL: 
        Comment: 
        Stacktrace: 
http://cyclone/reports/stackcommentemail.cfm?dynamicBBID=15003635






Keywords: topcrash
Summary: Crash when getting redirected at geocities (null aDocChannel) → Crash when redirected at geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel)

Comment 3

18 years ago
Crash is occuring in the OnEndDocumentLoad method in nsWalletService.cpp at the 
following line:

   channel->GetNotificationCallbacks(getter_AddRefs(interfaces));

The channel is null at this point.  This line was added by danm in order to get 
a parent window for a modal dialog.

Comment 4

18 years ago
Here's the patch to fix this.  Can someone give me a code review on this.

Index: nsWalletService.cpp
===================================================================
RCS file: /cvsroot/mozilla/extensions/wallet/src/nsWalletService.cpp,v
retrieving revision 1.79
diff -c -r1.79 nsWalletService.cpp
*** nsWalletService.cpp	2000/07/19 21:05:45	1.79
--- nsWalletService.cpp	2000/07/30 16:22:21
***************
*** 328,334 ****
                            nsCOMPtr<nsIInterfaceRequestor> interfaces;
                            nsCOMPtr<nsIPrompt> prompter;
  
!                           
channel->GetNotificationCallbacks(getter_AddRefs(interfaces));
                            if (interfaces)
                              interfaces->GetInterface(NS_GET_IID(nsIPrompt), 
getter_AddRefs(prompter));
                            if (!prompter)
--- 328,335 ----
                            nsCOMPtr<nsIInterfaceRequestor> interfaces;
                            nsCOMPtr<nsIPrompt> prompter;
  
!                           if (channel)
!                             
channel->GetNotificationCallbacks(getter_AddRefs(interfaces));
                            if (interfaces)
                              interfaces->GetInterface(NS_GET_IID(nsIPrompt), 
getter_AddRefs(prompter));
                            if (!prompter)

Comment 5

18 years ago
can't even log into geocities because of this bug using the 
Friday night 7/28 nsbeta2 candidate build on my win95 laptop.

looks like a high reward low risk fix kinda thing that should
go on the nsbeta2 radar..  

adding fix in had to status and keyword nsbeta2.
Keywords: nsbeta2
Summary: Crash when redirected at geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel) → Crash logining into geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel)
Whiteboard: fix in hand.

Comment 6

18 years ago
http://geocities.yahoo.com/home/ is the url I hit

Comment 7

18 years ago
jar just gave me a verbal approval for nsbeta2+ and he gave me a code review on 
this.  About to check in the fix on both the trunk and the m17 branch.
Whiteboard: fix in hand. → fix in hand. [nsbeta2+]

Comment 8

18 years ago
Fix is now checked in, both on trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
Updating QA Contact.
QA Contact: doronr → sairuh
i don't have a FreeBSD machine to vrfy this but, fwiw, i don't crash when going
to the above URL on my linux box [using 2000.07.31.04-m17 beta2 bits]. Randell,
could you also confirm that this is fixed for you? thx!

quickie check on other platforms: no prob on Mac 9.0 [same bits as linux] or on
winNT [2000.08.01.04-m17, beta2].
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
this was an XP bug,  should/can verfiy on win95/98/NT and probably Mac too.
yes, this is fixed (ie, no problem) on winNT and Mac.
(Reporter)

Comment 13

18 years ago
Problem still exists - I still get the assertion failure.  Fresh pull/build
8/1/00.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 14

18 years ago
Note: Pollmann@netscape.com has a freebsd machine that can be used.

Comment 15

18 years ago
Putting on [nsbeta2-] radar.  will get tested on Win95 and Win98 shortly.  But 
not critical to netscape 6 beta2.
Whiteboard: fix in hand. [nsbeta2+] → [nsbeta2-]fix in hand. [nsbeta2-]
works fine on win98, 2000.08.01.04-m17 pr2 branch bits.
Whiteboard: [nsbeta2-]fix in hand. [nsbeta2-] → fix in hand. [nsbeta2+]
ack, clobbered jan's whiteboard changes due to collision... entering 'em in...
Whiteboard: fix in hand. [nsbeta2+] → [nsbeta2-]fix in hand. [nsbeta2-]

Comment 18

18 years ago
works fine on win95, 2000.08.02.04-m17 pr2 branch bits.

Comment 19

18 years ago
wfm too on win95 8/2 m17 build.
(Reporter)

Comment 20

18 years ago
I should note that the problem invoked only the assertion failure when I
retested it; it did not crash.  I think the fix solved the crash (by adding some
error-checking), but didn't solve the base problem of an assertion failure.

I'd say the crash has been fixed.  The assertion failure which led (probably) to
the crash has not.  Perhaps a second bug report should be opened for that and
the crash reclosed.

Backtrace from the assertion failure:
 bt
#0  nsDebug::Assertion (aStr=0x28da7295 "Channel list is not empty.", 
    aExpr=0x28da728a "count == 0", aFile=0x28da6f85 "nsLoadGroup.cpp", 
    aLine=239) at nsDebug.cpp:184
#1  0x28cf6973 in nsLoadGroup::Cancel (this=0x8987980, status=2152398850)
    at nsLoadGroup.cpp:239
#2  0x28eace6b in nsDocLoaderImpl::Stop (this=0x898b700) at nsDocLoader.cpp:276
#3  0x28eab221 in nsURILoader::Stop (this=0x8176f30, aLoadCookie=0x898b718)
    at nsURILoader.cpp:619
#4  0x28e494f1 in nsDocShell::StopLoad (this=0x8970400) at nsDocShell.cpp:328
#5  0x28e53e53 in nsDocShell::InternalLoad (this=0x8970400, aURI=0x8c06480, 
    aReferrer=0x0, aOwner=0x0, aWindowTarget=0x0, aPostData=0x0, aLoadType=8, 
    aSHEntry=0x0) at nsDocShell.cpp:2628
#6  0x28e48d51 in nsDocShell::LoadURI (this=0x8970400, aURI=0x8c06480, 
    aLoadInfo=0x90537c0) at nsDocShell.cpp:258
#7  0x28e5a898 in nsRefreshTimer::Notify (this=0x91fe460, aTimer=0x8b46bc0)
    at nsDocShell.cpp:3929
#8  0x29bbb26a in ?? ()
   from /home/jesup/src/mozilla_work/mozilla/dist/bin/components/libtimer_gtk.so
#9  0x29bbb4b5 in ?? ()
   from /home/jesup/src/mozilla_work/mozilla/dist/bin/components/libtimer_gtk.so
#10 0x29bbb59b in ?? ()
   from /home/jesup/src/mozilla_work/mozilla/dist/bin/components/libtimer_gtk.so
#11 0x28b37b1f in ?? () from /usr/local/lib/libglib12.so.3
#12 0x28b36d17 in ?? () from /usr/local/lib/libglib12.so.3
#13 0x28b3731f in ?? () from /usr/local/lib/libglib12.so.3
#14 0x28b374a1 in ?? () from /usr/local/lib/libglib12.so.3
#15 0x28a6b6f3 in ?? () from /usr/X11R6/lib/libgtk12.so.2
#16 0x2897b125 in ?? ()
   from
/home/jesup/src/mozilla_work/mozilla/dist/bin/components/libwidget_gtk.so
#17 0x2849879e in ?? ()
   from
/home/jesup/src/mozilla_work/mozilla/dist/bin/components/libnsappshell.so
#18 0x80533c8 in main1 (argc=1, argv=0xbfbfd33c, nativeApp=0x0)
    at nsAppRunner.cpp:913
#19 0x8053b21 in main (argc=1, argv=0xbfbfd33c) at nsAppRunner.cpp:1093

Comment 21

18 years ago
Updating my tree and building to confirm on FreeBSD

Comment 22

18 years ago
Oh, lucky me - the fix went in before my last build.  My 7/31 FreeBSD build also 
asserts but does not crash.  I'd mark this fixed by morse's checkin.
(Assignee)

Comment 23

18 years ago
  Oh, well, I see those asserts, too. No crash. I believe the asserts mean the 
load group is being shut down while it still has a channel open; not totally 
unexpected behaviour during a redirect. cc:ing a networking guy for comment. But 
the crash is certainly gone. re-closing as "fixed." (and putting the nsbeta2+ 
back -- this bug describes a crash, not an assertion.)
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Summary: Crash logining into geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel) → Crash logging into geocities [@ nsWalletlibService::OnEndDocumentLoad (null aDocChannel)
Whiteboard: [nsbeta2-]fix in hand. [nsbeta2-] → [nsbeta2+]

Comment 24

18 years ago
Yeah, from what I could figure out was going on here-- the assertion is a safe 
one. 
Keywords: verifyme
vrfy using 2000.08.03.04-m17 on winnt, mac and linux rh.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.