Conflict between "clear private data on exit" and "show my windows and tabs from the last time": browser clears tab data and opens with one empty tab

RESOLVED DUPLICATE of bug 398817

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 398817
9 years ago
9 years ago

People

(Reporter: Brian Fink, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

I found a similar bug that had been listed as "resolved," so please be aware: (a) This is the same bug the other guy reported, and (b) It is definitely NOT resolved.

When preferences are set to "show all windows and tabs from the last time" and "always clear my private data when I close Firefox" with "browsing history" checked, the next time the browser is opened, one empty tab or one blank page appears. This does not occur if the private data is cleared manually while the tabs are still open, without previously selecting the clear-on-exit option. Apparently the browser closes all windows and tabs before clearing private data.

Reproducible: Always

Steps to Reproduce:
1. Tools > Options > Main > When Firefox starts > Show all windows and tabs from the last time.
2. Tools > Options > Privacy > Private Data > Always clear my private data when I close Firefox > Settings > Browsing History.
3. Open some tabs with arbitrary content. (at least 2 tabs)
4. Close Firefox.
5. Open Firefox.
Actual Results:  
When the browser reopened, none of my tabs from the previous session were present--only an empty page was displayed.

Expected Results:  
I expected to see all my tabs from the previous time, as before.

This is true for Firefox 3.0.4 and has not yet been tested on Firefox 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
(Reporter)

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 398817 ***

It really annoys me that you folks at Mozilla have KNOWN about this bug for quite a while and still refuse to take any action to address it! Look, it's really very simple. The problem is that when the routine runs, the browser has already closed. You can confirm this by checking the prefernce marked "ask me before clearing private data." The browser window closes, AND ONLY THEN does the dialog box appear. If the routine ran before the window closed, this bug would not exist. So many people can't be wrong!
(Reporter)

Comment 3

9 years ago
I just tested the bug on Firefox 2 and Firefox 2 works just fine. So this is to confirm that the bug arose in version 3. I hope this helps.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

9 years ago
Apparently a workaround exists. The source of the problem is a missing or changed sessionstore.js file. (see <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=366572#c18">comment 18 on bug 366572</a> for the solution)
(Reporter)

Comment 5

9 years ago
Anyway, when I closed the browser through the File menu and opened it again, all my tabs were restored as before, so at least we have a workaround until such time as the problem gets addressed.
Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html including section 2.2
You can reopen this bug if bug 398817 doesn't match your isse, not if you don't like the resolution of bug 398817
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398817
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> Please read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html including
> section 2.2
> You can reopen this bug if bug 398817 doesn't match your isse, not if you don't
> like the resolution of bug 398817
> 
> *** This bug has been marked as a duplicate of bug 398817 ***

The resolution to the problem appears to be to be bogus. What you're telling me is that as long as the bug remains, we have no appeal path open to us, am I right? Why should I have to close my browser through the file menu in order to keep my tabs? Is there some formal request we can make to have the original case reopened? At least 15 of us are dissatisfied with the "answer." And I thought it was an open source application!
>Is there some formal request we can make to have the original case reopened? 
You have to change the developers mind, the developer who closed the bug but I think he will not listen anymore, after shouting (all caps) in the bug and violating the etiquette in a very bad way. 

FYI: I also think that the case is invalid because you can't have both at once, the clear history and the session restore. Fixing bug 398817 would be a privacy breach but my opinion doesn't matter in this case.

>And I thought it was an open source application!
Firefox is of course an open source application. Get the source, modify it and build your own verion with bug 398817 fixed. Where is your problem ?
You must be mistaken if you think that open source means that everything that a few people want gets implemented.
(Reporter)

Comment 9

9 years ago
(In reply to comment #8)
> >Is there some formal request we can make to have the original case reopened? 
> You have to change the developers mind, the developer who closed the bug but I
> think he will not listen anymore, after shouting (all caps) in the bug and
> violating the etiquette in a very bad way. 
> 
> FYI: I also think that the case is invalid because you can't have both at once,
> the clear history and the session restore. Fixing bug 398817 would be a privacy
> breach but my opinion doesn't matter in this case.
> 
> >And I thought it was an open source application!
> Firefox is of course an open source application. Get the source, modify it and
> build your own verion with bug 398817 fixed. Where is your problem ?
> You must be mistaken if you think that open source means that everything that a
> few people want gets implemented.

I apologize for the shouting. I didn't read all the comments and jumped to a conclusion. I humbly ask for your patience as I and many others try once again to explain our own side of this issue.

If you delete the private data intentionally when the tabs are still open, and then restart the browser while electing not to delete the private data, the tabs (though not each tab's history) will restore as they should. Why should automatic clearing of private data be any different. Keep in mind that we actually selected "show... tabs...", not "show a blank page." This sort of feature tyranny is uncharacteristic of Mozilla! I'm totally and completely shocked! Such behavior may be expected from the likes of Internet Explorer, but not Firefox. Please understand that it's the latest page on each tab that we want to preserve, not the entire session data. Automatic settings used to make this more convenient for us. Please do not overreach in your zeal to increase privacy.
You need to log in before you can comment on or make changes to this bug.