Invalid characters in the Subject line (HTAB in Subject: header is displayed as �)

RESOLVED DUPLICATE of bug 271312

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 271312
9 years ago
8 years ago

People

(Reporter: localicer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.08 KB, application/x-zip
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4 (.NET CLR 3.5.30729)
Build Identifier: 3.0a3

When I receive an e-mail with UTF-8 charset, some characters in the Subject line are replaced with � symbols. This message is in Hungarian language.

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.

Comment 1

9 years ago
Could you attach email using File->Save as-> file
(Reporter)

Comment 2

9 years ago
Created attachment 350724 [details]
For request

The e-mail is attached.
Subject header is as follows. ( [CRLF]==0x0D0A, [HTAB]==0x09 )
> Subject: A(z) "FlashFXP" =?UTF-8?B?dGVybelr?=[CRLF]
>  =?UTF-8?B?IG1lZ3JlbmRlbOlz6XZlbA==?=[HTAB] kapcsolatos =?UTF-8?B?bWVnamVneXrpc2Vr?=[CRLF]
Same problem as Bug 271312.
 Bug 271312 : [HTAB] as white space char for header folding
 This bug   : [HTAB] at mid of mail subject data(just after a UTF-8 encoded atom)

Why mail sender puts [HTAB] in mail subject?
Mail sender expects extra spaces/indention at [HTAB] position like program source viewing?
Setting dependency to Bug 271312 before closing as DUP of it, for ease of search.
Depends on: 271312
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: Invalid characters in the Subject line → Invalid characters in the Subject line (HTAB in Subject: header is displayed as �)
Duplicate of bug: 271312

Updated

8 years ago
No longer depends on: 271312
You need to log in before you can comment on or make changes to this bug.