bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

when selecting text and right clicking an error came up saying "engine has no file!"

RESOLVED DUPLICATE of bug 427028

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 427028
10 years ago
9 years ago

People

(Reporter: George Prowse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

When i selected some text and right click this error pops up which looks like a stack trace:

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],hidden)
5:()
6:()
7:currentEngine()
8:()
9:CM_initMenu([object XULElement],[object XULElement])
10:nsContextMenu([object XULElement],[object XULElement])
11:onpopupshowing([object MouseEvent])

I am unsure if it is serious but after I ok'd it it goes away and the usual menu comes up.

I have just this moment done an update and I have a firefox update included so i'll restart after posting this just to be safe.

Reproducible: Always

Steps to Reproduce:
1. select text
2. right clik
3. profit!
Actual Results:  
this: 

ASSERT: *** Search: _installLocation: engine has no file!
Stack Trace: 
0:ENSURE_WARN(false,_installLocation: engine has no file!,2147500037)
1:()
2:()
3:()
4:epsGetAttr([object Object],hidden)
5:()
6:()
7:currentEngine()
8:()
9:CM_initMenu([object XULElement],[object XULElement])
10:nsContextMenu([object XULElement],[object XULElement])
11:onpopupshowing([object MouseEvent])


Expected Results:  
plain right-click menu

Ubuntu intrepid
(Reporter)

Comment 1

10 years ago
I'm afraid it seems to have been fixed, sorry about that
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
That an assertion, you have a debug build instead of a optimized one.
fixed can only be used if there is a patch in the bug, not if it works again for you.
Resolution: FIXED → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 427028
You need to log in before you can comment on or make changes to this bug.