Missing loginManager files in Sunbird

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: gareed105, Unassigned)

Tracking

Trunk
x86
Linux

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20081128 Calendar/1.0pre

I installed the latest GData Provider 0.6pre to open my Google calendars and set up the calendars in Sunbird.  When I launch Sunbird, I am prompted for the Google Calendar password even though I checked the "save" box at the prompt.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



The error console gives the following messages.

Error: i is undefined
Source File: file:///xxx/Apps/sunbird/modules/XPCOMUtils.jsm
Line: 115

Failed to load XPCOM component: /xxx/Apps/sunbird/components/nsLoginManager.js

Error: a._updateVisibleText is not a function
Source File: chrome://global/content/bindings/textbox.xml
Line: 210
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
This should fix itself with bug 239131 fixed, please reopen if not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 239131
Standard8 correctly noted that this isn't going to fix sunbird. For thunderbird see bug 239131, keeping this one for Sunbird.

Did this by chance fix itself in 1.0pre ?
Status: RESOLVED → UNCONFIRMED
Component: Provider: GData → Sunbird Only
QA Contact: gdata-provider → sunbird
Resolution: DUPLICATE → ---
Summary: Google Calendar password not saved in Sunbird → Missing loginManager files in Sunbird
(Reporter)

Comment 3

10 years ago
No, it is not fixed in the latest sunbird 1.0pre (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090109 Calendar/1.0pre).  The error console gives the following messages.

Error: l.usernameField is null
Source File: file:///xxx/sunbird/components/storage-mozStorage.js
Line: 691

Error: Assert failed: [Exception... "'[JavaScript Error: "l.usernameField is null" {file: "file:///xxx/sunbird/components/storage-mozStorage.js" line: 691}]' when calling method: [nsILoginManagerStorage::addLogin]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///xxx/sunbird/components/nsLoginManager.js :: anonymous :: line 431"  data: yes]
2: [file:///xxx/sunbird/modules/calAuthUtils.jsm:154] calPasswordManagerSave
3: [file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleUtils.js:327] passwordManagerSave
4: [file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:435] cGS_onResult
5: [file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:246] cGR_fail
6: [file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:258] cGR_succeed
7: [file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:371] cGR_onStreamComplete

Source File: file:///xxx/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/calendar-js/calUtils.js
Line: 968
bug 463058 was fixed, which might change the errors a bit. Please check again in at least 12 hours or when the next nightly is there.
(Reporter)

Comment 5

10 years ago
Still not fixed.  I tested on today's build (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090117 Calendar/1.0pre) with today's build of gdata-provider and a new profile.  Even though I checked the save password box during setup of the calendar, the password is not saved at startup or in the view saved passwords list.

I got the following error messages in the console at startup.

Error: l.usernameField is null
Source File: file:///xxx/Apps/sunbird/components/storage-mozStorage.js
Line: 709

Error: Assert failed: [Exception... "'[JavaScript Error: "l.usernameField is null" {file: "file:///xxx/Apps/sunbird/components/storage-mozStorage.js" line: 709}]' when calling method: [nsILoginManagerStorage::addLogin]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///xxx/Apps/sunbird/components/nsLoginManager.js :: anonymous :: line 431"  data: yes]
2: [file:///xxx/Apps/sunbird/modules/calAuthUtils.jsm:140] calPasswordManagerSave
3: [file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleUtils.js:327] passwordManagerSave
4: [file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:435] cGS_onResult
5: [file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:246] cGR_fail
6: [file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:258] cGR_succeed
7: [file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:371] cGR_onStreamComplete

Source File: file:///xxx/Apps/sunbird/modules/calUtils.jsm -> file:///xxx/Apps/sunbird/calendar-js/calUtils.js
Line: 968
(Reporter)

Comment 6

10 years ago
Looks like some of the same types of error messages are in Bug 473973.
https://bugzilla.mozilla.org/show_bug.cgi?id=473973
(Reporter)

Comment 7

10 years ago
I tested for this bug on today's build (Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.9.1b3pre) Gecko/20090120 Calendar/1.0pre) with today's build of
gdata-provider and a new profile, and it appears to be fixed.

However, there is the following error message in the console.

Error: Assert failed: TypeError: logins[0].clone is not a function
2: [file:///home/gregg/Apps/sunbird/modules/calAuthUtils.jsm:140] calPasswordManagerSave
3: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleUtils.js:195] passwordManagerSave
4: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:437] cGS_onResult
5: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:246] cGR_fail
6: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:258] cGR_succeed
7: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:371] cGR_onStreamComplete

Source File: file:///home/gregg/Apps/sunbird/modules/calUtils.jsm -> file:///home/gregg/Apps/sunbird/calendar-js/calUtils.js
Line: 968

Should I file a bug?

Thanks.
(In reply to comment #7)
> I tested for this bug on today's build (Mozilla/5.0 (X11; U; Linux i686;
> en-US; rv:1.9.1b3pre) Gecko/20090120 Calendar/1.0pre) with today's build of
> gdata-provider and a new profile, and it appears to be fixed.

Resolving this bug as WFM.


> However, there is the following error message in the console.
> 
> Error: Assert failed: TypeError: logins[0].clone is not a function
> 2: [file:///home/gregg/Apps/sunbird/modules/calAuthUtils.jsm:140]
> calPasswordManagerSave
> 3: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleUtils.js:195]
> passwordManagerSave
> 4: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleSession.js:437]
> cGS_onResult
> 5: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:246]
> cGR_fail
> 6: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:258]
> cGR_succeed
> 7: [file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/MyStuff/sunbird/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleRequest.js:371]
> cGR_onStreamComplete
> 
> Source File: file:///home/gregg/Apps/sunbird/modules/calUtils.jsm ->
> file:///home/gregg/Apps/sunbird/calendar-js/calUtils.js
> Line: 968
> 
> Should I file a bug?

This error should be gone with today's nightly build (bug 474552).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.