Crash on pressing button in javascript window

VERIFIED DUPLICATE of bug 42670

Status

()

Core
DOM: Core & HTML
P3
critical
VERIFIED DUPLICATE of bug 42670
18 years ago
18 years ago

People

(Reporter: shrirang khanzode, Assigned: jst)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I see this on today's windows build (2000072704)

Steps:
Visit the page.
Click on 'Enhanced' to open another window.
Observe that a small window titled' The Comet Cursor' opens up.
Click on 'No' to see the browser crash.
(Assignee)

Comment 1

18 years ago
The problem here is the the page triggers a JS error, and the JS error handler
for some reason triggers more JS errors, and the JS error handler... The result
of this is that we overflow the stack while infinitely recurse into
NS_ScriptErrorReporter()...

NS_ScriptErrorReporter() needs reentrancy guards, I hacked that up and the crash
is gone...
Status: NEW → ASSIGNED

Comment 2

18 years ago
spam: Adding crash keyword...
Keywords: crash
(Assignee)

Comment 3

18 years ago
Nominating for beta3, adding the recursion protection is trivial and definitely
worth it for nsbeta3 since it prevents the crash...
Keywords: nsbeta3

Comment 4

18 years ago
Marking nsbeta3+
Whiteboard: [nsbeta3+]

Comment 5

18 years ago
Adding annotation to the status whiteboard
Whiteboard: [nsbeta3+] → [nsbeta3+] Have hack
(Assignee)

Comment 6

18 years ago
Transfering nsbeta3 keywords and marking this as a dup of bug 42670.

*** This bug has been marked as a duplicate of 42670 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Whiteboard: [nsbeta3+] Have hack

Comment 7

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.