news (NNTP) messages do not load

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
When I load a list of news (NNTP) messages in the thread pane and then select an entry in the list using the latest Shredder nightly for Linux, nothing happens.  The throbber doesn't throb, and the message pane doesn't unload its current content and load the message I selected.

If I open the message in a new window, a blank window opens.  And if I open the message in a new tab, a blank tab opens (although its title contains the subject of the message).

I see this behavior with two different news servers, news.mozilla.org and news.pair.com.  Nothing appears in the error console except the following error when I try to open the message in a new window:

Error: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMessenger.msgHdrFromURI]
Source file: chrome://messenger/content/messageWindow.js
Line: 383

This seems like something that would have already been filed, but I couldn't find a relevant bug searching through bug reports filed in the last two weeks (I'm pretty sure it was working less than two weeks ago when I last read through newsgroups).

I don't see the problem on the latest nightly for Mac.  But it happens every time on Linux, and switching from threaded to unthreaded mode doesn't make a difference.

Comment 1

10 years ago
cc'ing other linux users to see if they're seeing this as well with the lastest nightlies - the stand-alone message window issue could be bug 467012 which is supposed to be fixed by a m-central backout.
(Reporter)

Comment 2

10 years ago
I couldn't reproduce with a fresh profile, so I dug through my preferences and discovered this was caused by some experimentation I had done (and then forgotten about) with sending news: URLs to my browser using the news.protocol-handler.* preferences.

After resetting those preferences, everything works great, and I also no longer see that error when I open a message in a new window.

Sorry about the false alarm.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.