If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

abort (PR_ASSERT) on closed FTP control connection

VERIFIED FIXED

Status

()

Core
Networking
P3
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: jesup, Assigned: Robert John Churchill)

Tracking

({crash})

Trunk
x86
FreeBSD
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Crashed when I selected an FTP page off the Go menu.  The control connection had
probably timed out.  It appears this might be related to IPv6 due to the
assertion (note: FreeBSD 4.1 supports IPv6).

Assertion failure: mIPv6Checked == PR_FALSE, at nsFtpConnectionThread.cpp:174

Program received signal SIGABRT, Aborted.
0x28358c74 in kill () from /usr/lib/libc_r.so.3
(Reporter)

Comment 1

18 years ago
Created attachment 12044 [details]
Backtrace of failure with dump of variables
(Reporter)

Updated

18 years ago
(Reporter)

Updated

18 years ago
Keywords: crash
(Reporter)

Comment 2

18 years ago
Added crash keyword

Comment 3

17 years ago
Created attachment 13143 [details]
Stacktrace of a probably similar crash on linux

Comment 4

17 years ago
I didn't want to open a new bug, so I just added an attachment of a crash on the
same assertion. The last thing I did before the crash was clicking on an ftp
URL. Before that I did nothing in the browserwindow for several minutes. Mozilla
build is from CVS of today. OS is Linux 2.2.16. Hope that helps somebody.
(Reporter)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
->rjc
Assignee: gagan → rjc
(Reporter)

Comment 6

17 years ago
Upping severity since it's a crash
Severity: normal → critical
(Assignee)

Comment 7

17 years ago
Removed the faulty assert.  Let's see if the connection recovery code works.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
testing for tever

Comment 9

17 years ago
Randell are you seeing this on FreeBSD anymore?

Comment 10

17 years ago
have not heard back from reporter.  closing
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.