can't run checksetup.pl after updating localconfig, didn't find remote mysql database

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Ronny Freigang, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111319 CentOS/3.0.4-1.el5.centos Firefox/3.0.4
Build Identifier: 3.2

I have installed the fresh bugzilla 3.2 release and run checksetup.pl first time. The mysql database resides on remote host and is from version 2.20.

First run works fine, all required perl modules found. I edit the localconfig and put my remote mysql database host, user and password into it.

I run checksetup.pl again and get error, that he can't connect to my database.
But he is trying to get an database with the local hostname, not the remote one i configured in localconfig. On local host is no mysql database server installed, so he can't connect. I tried to disable $db_check, but no change.

"mysql -h remotehost -u bugs -p bugzilla" runs fine, so no problem in mysql config.

The bugzilla 3.2 RC2 on the same host runs fine! So it must be a failure that get into with the last changes between RC2 and release.



Reproducible: Always

Steps to Reproduce:
1.untar, run checkconfig.pl first time
2.edit localconfig
3.run checkconfig.pl again
Actual Results:  
can't connect to mysql remote database

Expected Results:  
connect to database and start conversion

Comment 1

10 years ago
There were no changes in the installation or database code between rc2 and the final release. This must be a local problem. You can ask for support using the support-bugzilla mailing list, though, described here:

  http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
When there wasn't any changes, why the RC2 runs fine?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

10 years ago
That is something that you will have to figure out. But this is not a bug in Bugzilla, so do not re-open this bug. If you have any more questions, you can ask them on the support list that I described above.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.