Firefox 3 no longer displays favicons (.ico image files) within browser windows/tabs

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: firefox.bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_4_11; en) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Earlier versions of Firefox used to be able to display favicons which were used as image elements (IMG SRC) in web pages. They are sometimes used/useful as mini-icons for bullets in HTML lists. As of Firefox 3, when an IMG SRC attribute references a .ico file, it displays as a hollow rectangle image-placeholder rather than the favicon.

Reproducible: Always

Steps to Reproduce:
1. add an <img src="url_of_some_favicon" alt="favicon" /> to any html web page
2. open the page in Firefox 3
Actual Results:  
Got a hollow rectangular image-placeholder where the favicon would've appeared in earlier versions of Firefox

Expected Results:  
favicon displayed in the web page

Works fine in Camino Version 1.6.5 (1.8.1.18 2008111212); i.e., Gecko 1.8.1.18 rendering engine.
I can see favicons in the tab bar just fine in Trunk. Please try in Safe Mode. you can read http://new.quality.mozilla.org/bug-writing-guidelines for other steps as well.
(Reporter)

Comment 2

9 years ago
I retract this bug report. Disabling the ImgLikeOpera extension, which restricts the browser to displaying only cached images, corrects the problem.
OK, than, not a bug in Firefox. Thank you for researching this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.