Component.utils.import throws confusing error if "imported" over more than one level

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: pennywise, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Waterseal Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Waterseal Firefox/3.0.4

Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Quelldatei: secondfile.js
Error: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Quelldatei: firstfile.js


This errors occurs, if you have the following construct:

firstfile.js:
Component.utils.import("resource://secondfile.js");

secondfile.js:
Component.utils.import("resource://thirdfile.js");

and then have a syntax error (or some other) inside of thirdfile.js. It's kind of annoying that FF throws a "file not found" because of a syntax error in third level.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
File not found (firstfile.js, secondfile.js)

Expected Results:  
Syntax error in thirdfile.js
(Reporter)

Comment 1

9 years ago
I've created a minimalistic xpi as a test case. In /content/lib/otherLib.js I'm creating a syntax error, which is shown as followed in the JS Console:

Fehler: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Quelldatei: file:///content/lib/someLib.js
Zeile: 3
 ----------
Fehler: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Quelldatei: chrome://cuimport/content/Cuimport.js
Zeile: 1

See attached file
(Reporter)

Comment 2

9 years ago
Created attachment 353425 [details]
minimalistic xpi for Components.utils.import failure on more then two levels
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.