Firefox does not save the tabs from last time correctly

RESOLVED DUPLICATE of bug 444069

Status

()

--
critical
RESOLVED DUPLICATE of bug 444069
10 years ago
9 years ago

People

(Reporter: great.wyrm.green.dragon, Unassigned)

Tracking

({dataloss})

3.0 Branch
x86
Linux
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111318 Ubuntu/8.10 (intrepid) Firefox/3.0.4

I own a website (a wiki) and I for the most part I have around 10 to 100 tabs open at all times.

I used to always pkill firefox after using it to retain the correct tabs from last time.  This worked flawlessly; the tabs I had open from last time were always correctly saved, and there were no problems.  I ended up restoring the previous session every time I opened firefox and the exact same tabs I had open from last time popped up.  It worked.

Then I upgraded my firefox (through the update-manager of course), and everything changed.  A new option (save tabs and quit) showed up.  I tried out this option, however it did not (and maybe still does not?) work correctly.  Maybe because of how many tabs I always have open or something it did not save the correct tabs I had open; sometimes it showed old tabs I had open an hour or so before I closed firefox, sometimes only a blank screen showed up.  I stopped using this buggy feature and went back to the old pkill way of dealing with firefox.  Now, a real bug is present.  Firefox (when pkilled) does not retain the tabs from last time correctly.  I have no idea what changed, however now when I pkill firefox and restore the previous session at a later date it restores tabs I had open from an earlier time - NOT the exact same tabs I had open when I pkilled firefox.

Reproducible: Sometimes

Steps to Reproduce:
1.  Paste this into the homepage area (so they all show up).  Then change the homepage back to the standard page, pkill firefox, and restore the session.  I doubt the same tabs will show up.

http://www.dandwiki.com/w/index.php?title=Special:Recentchanges&limit=50&hidepatrolled=1http://www.dandwiki.com/w/index.php?title=Talk:User_Magical_Weapons&action=edit&section=2|http://www.dandwiki.com/wiki/Talk:Bodily_Relics|http://www.dandwiki.com/wiki/Talk:4e_Creatures_by_Level|http://www.dandwiki.com/w/index.php?title=Talk:4e_Homebrew&action=edit&section=new|http://www.dandwiki.com/w/index.php?title=Great_Annulat_%28DnD_Equipment%29&curid=39024&diff=287476&oldid=251076|http://www.dandwiki.com/w/index.php?title=Weapon_Descriptions&action=edit|http://www.dandwiki.com/wiki/Talk:Bodily_Relics|http://en.wikipedia.org/wiki/Anton_Chekhov#Bibliography|http://www.dandwiki.com/wiki/FA|http://www.dandwiki.com/w/index.php?title=Talk:Witch%2C_by_LD_%28DnD_Class%29&curid=37162&diff=288210&oldid=249066&rcid=296295|http://www.dandwiki.com/w/index.php?title=Talk:Rod_of_Chance_%28DnD_Equipment%29&curid=35687&diff=288184&oldid=271190|http://www.dandwiki.com/wiki/Unfledged_%28DnD_Class%29|http://www.dandwiki.com/w/index.php?title=Gunblade&rcid=296260|http://www.dandwiki.com/w/index.php?title=True_Celestial_%28DnD_Creature_Subtype%29&curid=37304&diff=288149&oldid=249591|http://www.dandwiki.com/w/index.php?title=Xhato_%28DnD_Class%29&rcid=296215|http://www.dandwiki.com/wiki/Book_of_Orcus%27s_Hate_%28DnD_Equipment%29|http://www.dandwiki.com/wiki/Talk:Rod_of_Chance_%28DnD_Equipment%29|http://www.dandwiki.com/w/index.php?title=Talk:Elven_Starstepper_%28DnD_Race%29&curid=14383&diff=288124&oldid=240739&rcid=296211|http://www.dandwiki.com/w/index.php?title=Elven_Starstepper_%28DnD_Race%29&curid=10121&diff=288122&oldid=257332|http://www.dandwiki.com/w/index.php?title=Talk:Oozebound_%28DnD_Prestige_Class%29&curid=34727&diff=288119&oldid=288015|http://www.dandwiki.com/wiki/Talk:Unorthodox_Cave-in_Clearing_%28DnD_Variant_Rule%29|http://www.dandwiki.com/w/index.php?title=Shadowcaster_%28Plushie_Substitution_Level%29&curid=44531&diff=288079&oldid=288068|http://www.dandwiki.com/wiki/4e_Creature_Preload|http://www.dandwiki.com/w/index.php?title=Special:Recentchanges&hidepatrolled=1|http://www.dandwiki.com/wiki/Talk:Clothen_Master_%284e_Class%29|http://www.dandwiki.com/w/index.php?title=Sonic_Shock_%28DnD_Spell%29&curid=42536&diff=288579&oldid=274954&rcid=296658|http://www.dandwiki.com/w/index.php?title=Bonespur_%28DnD_Prestige_Class%29&curid=43020&diff=288575&oldid=286270&rcid=296654|http://www.dandwiki.com/w/index.php?title=Boatman_of_Styx_%28DnD_Prestige_Class%29&curid=43583&diff=288564&oldid=281650&rcid=296643|http://www.dandwiki.com/wiki/Talk:Armageddon_%28DnD_Spell%29|http://www.dandwiki.com/w/index.php?title=Breathformer_%28DnD_Class%29&curid=39356&diff=288542&oldid=288538&rcid=296623|http://www.dandwiki.com/wiki/Discussion:D%26D_WIki_Magazine|http://www.dandwiki.com/wiki/Armageddon_%28DnD_Spell%29|http://www.dandwiki.com/wiki/UA_talk:Bell_Curve_Rolls|http://www.dandwiki.com/wiki/DnD_Creature_Templates|http://www.dandwiki.com/wiki/DnD_Creatures|http://www.dandwiki.com/wiki/DnD_Creature_Instructions|http://www.dandwiki.com/w/index.php?title=DnD_CR_40_or_more_Creatures&action=submit|http://www.dandwiki.com/w/index.php?title=User_D20M_Base_Classes_with_Descriptions&action=submit|http://www.dandwiki.com/wiki/Main_Plasmids|http://www.dandwiki.com/w/index.php?title=Category:Tome_of_the_Occult&rcid=296912|http://www.dandwiki.com/wiki/Classes_%28Norselands%29|http://www.dandwiki.com/w/index.php?title=Tome_of_the_Occult_%28DnD_Other%29&curid=44569&diff=288847&oldid=288838|http://www.dandwiki.com/w/index.php?title=Talk:Knife_Thrower_%28DnD_Class%29&curid=8537&diff=288624&oldid=288585&rcid=296704|http://www.dandwiki.com/w/index.php?title=Shinobi_%28DnD_Prestige_Class%29&curid=20426&diff=288623&oldid=233659|http://www.dandwiki.com/w/index.php?title=Evil_Sucking_Thing_of_Doom_%28DnD_Creature%29&curid=38071&diff=288606&oldid=281040&rcid=296686|http://www.dandwiki.com/w/index.php?title=Talk:Battle_Mage_%28DnD_Class%29&curid=43915&diff=288605&oldid=284606&rcid=296685|http://www.dandwiki.com/wiki/Discussion:D%26D_WIki_Magazine|http://www.dandwiki.com/w/index.php?title=Shadow_Puppet_%28DnD_Feat%29&rcid=296595|http://www.dandwiki.com/w/index.php?title=Shadowcaster_%28Plushie_Substitution_Level%29&curid=44531&diff=288511&oldid=288079&rcid=296594|http://www.dandwiki.com/w/index.php?title=Speaker_For_The_Dead_%284e_Paragon_Path%29&curid=42934&diff=288494&oldid=277621&rcid=296577|http://www.dandwiki.com/wiki/Spell_Bow_%284e_Class%29|http://www.dandwiki.com/wiki/Geass_Knight_%28DnD_Class%29|http://www.dandwiki.com/wiki/Requests_for_Adminship/Ganteka|http://www.dandwiki.com/wiki/User_talk:Ganteka#Mitchellto.21|http://www.dandwiki.com/w/index.php?title=Special:Recentchanges&limit=50&hidepatrolled=1|http://www.dandwiki.com/cgi-bin/patroller.cgi|http://www.dandwiki.com/w/index.php?title=Heavenly_Sword_%28DnD_Monk_Fighting_Style%29&curid=23190&diff=289262&oldid=110132&rcid=297363|http://www.dandwiki.com/wiki/Shadowstabber_%28DnD_Equipment%29|http://www.dandwiki.com/wiki/Dabbler_%284e_Class%29|http://www.dandwiki.com/w/index.php?title=Gunblade_%28DnD_Equipment%29&curid=44539&diff=289243&oldid=289054|http://www.dandwiki.com/w/index.php?title=Talk:Least_Voraxia_%28DnD_Feat%29&curid=6734&diff=289235&oldid=106324&rcid=297336|http://www.dandwiki.com/w/index.php?title=Red_Mage_%28DnD_Class%29&curid=10070&diff=289209&oldid=283761&rcid=297310|http://www.dandwiki.com/wiki/Multiclass_%28DnD_Feat%29|http://www.dandwiki.com/w/index.php?title=Talk:4e_User_Base_Classes_with_Descriptions&curid=40368&diff=289239&oldid=260968&rcid=297340|http://www.dandwiki.com/wiki/Dark/Light_Companion_%28DnD_Feat%29|http://www.dandwiki.com/w/index.php?title=Special:Recentchanges&hidepatrolled=1|http://www.dandwiki.com/w/index.php?title=Aiton_Amazons_%28DnD_Race%29&curid=40270&diff=289443&oldid=288412&rcid=297543|http://www.dandwiki.com/w/index.php?title=Hashshashin_%28DnD_Class%29&curid=36810&diff=289402&oldid=283567&rcid=297502|http://www.dandwiki.com/w/index.php?title=Ribbon_Blade_%28DnD_Equipment%29&rcid=297499|http://www.dandwiki.com/w/index.php?title=Dabbler_%284e_Class%29&curid=44736&diff=289391&oldid=289250&rcid=297491|http://www.dandwiki.com/w/index.php?title=Talk:Hardy_Stock&rcid=297471|http://www.dandwiki.com/w/index.php?title=Hardy_Stock&rcid=297469|http://www.dandwiki.com/wiki/Unfledged_%28DnD_Class%29|http://www.dandwiki.com/w/index.php?title=Requests_for_Adminship/Ganteka&curid=44721&diff=289362&oldid=289176&rcid=297462|http://www.dandwiki.com/w/index.php?title=Elves%2C_Luck_%28DnD_Race%29&curid=23857&diff=289355&oldid=280122|http://www.dandwiki.com/wiki/Mogul_Locomotive_%28D20_Modern_Vehicle%29|http://www.dandwiki.com/w/index.php?title=Elves%2C_Blood_%28DnD_Race%29&curid=29330&diff=289347&oldid=279834|http://www.dandwiki.com/w/index.php?title=Boiling_Sphere_%28DnD_Spell%29&action=edit&oldid=289337|http://www.dandwiki.com/wiki/Special:Recentchanges|http://www.dandwiki.com/w/index.php?title=Gunblade_%28DnD_Equipment%29&curid=44539&diff=289610&oldid=289243&rcid=297715|http://www.dandwiki.com/wiki/Gunblade%2C_Melee_%28DnD_Equipment%29|http://www.dandwiki.com/w/index.php?title=Footman%27s_Lance_%28DnD_Equipment%29&rcid=297705|http://www.dandwiki.com/w/index.php?title=Living_Arrow_%28DnD_Spell%29&curid=41823&diff=289599&oldid=269679&rcid=297703|http://www.dandwiki.com/w/index.php?title=Elves%2C_Ghost_%28DnD_Race%29&curid=38971&diff=289583&oldid=255346|http://www.dandwiki.com/w/index.php?title=Cambion_%284e_Race%29&curid=42603&diff=289579&oldid=287951&rcid=297684|http://www.dandwiki.com/w/index.php?title=Talk:Azure_Knight_%28DnD_Prestige_Class%29&curid=44021&diff=289577&oldid=289173&rcid=297682|http://www.dandwiki.com/w/index.php?title=Necromancer_%284e_Paragon_Path%29&curid=42343&diff=289576&oldid=289552&rcid=297681|http://www.dandwiki.com/w/index.php?title=Azure_Knight_%28DnD_Prestige_Class%29&curid=43661&diff=289575&oldid=282290|http://www.dandwiki.com/wiki/Barbarian_Powers_%284e_Power_List%29|http://www.dandwiki.com/wiki/%2APLAYTEST%2A_Warrior_of_Rage_%284e_Feat%29|http://www.dandwiki.com/w/index.php?title=4e_Multiclass_Feats&curid=39671&diff=289566&oldid=255965|http://www.dandwiki.com/wiki/Special:AddData/Form:3.5e_Deity/MyDeity_%28DnD_Deity|http://www.dandwiki.com/wiki/Special:EditData/Form:DnD_Spell/MySpell_%28DnD_Spell%29|http://www.dandwiki.com/w/index.php?title=Template:3e_Spell&action=edit|http://www.dandwiki.com/wiki/Template:3.5e_Deity|http://www.dandwiki.com/wiki/Template:3.5e_Deity_%28Form_Input%29|http://www.dandwiki.com/wiki/Form:DnD_Spell|http://www.dandwiki.com/wiki/Eijilund_Plushies_%28DnD_Race%29|http://www.dandwiki.com/w/index.php?title=Form:3.5e_Deity&action=edit|http://www.dandwiki.com/wiki/Template:3.5e_Deity_%28Form_Input%29|http://www.dandwiki.com/wiki/Special:Search?search=compctxt&go=Go|http://www.dandwiki.com/w/index.php?title=Form:DnD_Spell&action=edit|http://www.dandwiki.com/w/index.php?title=Template:3e_Spell_Block&action=edit|http://www.dandwiki.com/w/index.php?title=Form:3.5e_Deity&action=edit|http://www.dandwiki.com/wiki/User:Green_Dragon

2.  They to use the "save tabs from last time" option and see if it works correctly.

Comment 1

10 years ago
Windows: "Show my windows and tabs from last time" after shutting down using the cross button hasn't worked in -any- version since FF 3. It works, however, if I select Exit from the File menu. It' SO annoying. Is there at least a way to disable the cross to avoid clicking it by mistake? I thought I'd posted about this bug in the past, but apparently not. I used FF 2 until a couple of days ago when FireFTP required version 3+. :(
I'll try the "OK to take it and work on it" option.
Still an issue with Firefox 3.5.2?
Component: Tabbed Browser → Session Restore
Keywords: dataloss
QA Contact: tabbed.browser → session.restore
Whiteboard: [closeme 2009-09-02]
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2009-09-02]
Duplicate of bug: 444069
You need to log in before you can comment on or make changes to this bug.