Closed Bug 467338 Opened 11 years ago Closed 11 years ago

Closing task or calendar tab with other tab focussed breaks the focussed tab

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: Fallen)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081130 Lightning/1.0pre Shredder/3.0b1pre

(Lightning builds of the same date).

Steps to reproduce:

1) Open Calendar and Task Tabs.
2) Focus the Calendar tab
3) Close the Task tab by clicking on its 'x'.

Actual Results:

Left-hand pane on the calendar tab is blanked. Calendar tab has to be closed and reopened for it to be repaired.

Expected Results:

No change to Calendar tab.

Also fails if you focus the task tab and close the calendar tab.
Flags: tb-integration?
Duplicate of this bug: 471545
Flags: wanted-calendar1.0?
OS: Mac OS X → All
Hardware: x86 → All
Flags: wanted-calendar1.0? → blocking-calendar1.0+
Confirmed. Berend, it seems the modeBroadcaster doesn't correctly understand which mode is being switched to. When following the exact STR above, the modeBroadcaster thinks we are in mail mode instead of calendar mode.


tb-integration: This needs to be fixed for 1.0 anyway, no need to burden the tb-integration list.
Flags: tb-integration?
Attached patch Fix - v1 β€” β€” Splinter Review
Ah I found the problem: we were switching to mail mode each time a tab was closed, regardless of which tab was active. This patch should be relativly easy to test and review. Mark, could you review this patch? If you'd prefer not to, please re-assign review to berend or maybe asuth.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #357795 - Flags: review?(bugzilla)
Whiteboard: [needs review]
Attachment #357795 - Flags: review?(bugzilla) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/fa3b7e36fca3>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs review]
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.