Shift-reload doesn't force reload from server, even though return in URL bar does

VERIFIED DUPLICATE of bug 21137

Status

()

Core
Networking: Cache
P3
normal
VERIFIED DUPLICATE of bug 21137
18 years ago
18 years ago

People

(Reporter: ekrock's old account (dead), Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using Commercial 2000072508 on WinNT 4.0 SP4.

What happened:
1) I found a bug report marked nsbeta3+ instead of [nsbeta3+]
2) I added the brackets and hit Commit
3) I clicked the link to go back to the bug, but the brackets weren't there
(isn't this the known bug where IIRC we load from cache even though we
shouldn't? cc:ing jar who knows about that bug)
4) pressed shift key and clicked reload arrow in toolbar

Expected: shift-reload would force reload of page from Net, showing brackets
Actual: shift-reload did *not* force reload from Net; still no brackets

However, when I then clicked the mouse caret in the Location bar and hit return,
the page was finally reloaded from the Net and the brackets appeared
(Assignee)

Updated

18 years ago
Keywords: nsbeta3

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 1

18 years ago
this should have been fixed by now (right neeti?) this is the same bug as the 
bugzilla one (I forget the number)
(Assignee)

Comment 2

18 years ago
No, this is a different bug. I just checked shift+reload is not hooked up yet.
Currently, the channel has a FORCE_VALIDATE load attribute set for just reload, 
and also shift_reload. On a shift+reload, the channel should have the load 
attribute set to FORCE_RELOAD.

Neeti
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

18 years ago
 I think this a dup of 21137

*** This bug has been marked as a duplicate of 21137 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.