western.org -- Cannot Submit Loan Application from Any Gecko Browser

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED INVALID
10 years ago
3 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13 NOT Firefox/2.0.0.18

Using SeaMonkey 1.1.13 spoofing Firefox 2.0.0.18, I tried to submit an application for an automobile loan at Western Federal Credit Union (WFCU).  I completed the entire process to the point where I print the application for my own records.  

Then I selected the "Submit Application" button.  I got an error dialog popup saying that the application was still being processed.  Selecting the OK button on the popup gave me the same popup a second time.  Selecting the OK button again, the popup was dismissed -- until I selected the "Submit Application" button again.  

I called WFCU and talked to their loan department.  They informed me that their system cannot handle online loan applications from Firefox (or from Safari).  

Reproducible: Always




Using SeaMonkey, I have no trouble viewing my various accounts at WFCU, using their online bill-payment service, or transferring funds between my accounts.  I spoof Firefox because some WFCU Web capabilities use UA sniffing for that browser instead of sniffing for Gecko.  However, this bug report is not about a failure to sniff for Gecko; it's about a failure of a Web site to allow any Gecko browser to perform an important function.  

I will be writing a letter to WFCU's president with a copy to their Supervisory Committee (equivalent to an audit committee).

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 1

6 years ago
In the past week, Western Federal Credit Union switched over to a completely new, redesigned Web site, making this bug report obsolete as "overcome by events" (OBE).  If the new site has the same problem, I will submit a new Tech Evangelism but report.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.