If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsCookie.cpp is doing it's own URL parsing.

VERIFIED DUPLICATE of bug 47437

Status

()

Core
Networking: Cookies
P3
normal
VERIFIED DUPLICATE of bug 47437
17 years ago
17 years ago

People

(Reporter: Judson Valeski, Assigned: Judson Valeski)

Tracking

({embed, footprint})

Trunk
x86
Linux
embed, footprint
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3])

(Assignee)

Description

17 years ago
In order to be consistent in URL parsing, and to reduce bloat/code duplication,
we need to make nsCookie.cpp use nsIURI and friends so it gets the parsing for
free.
(Assignee)

Updated

17 years ago
Keywords: embed, footprint
(Assignee)

Comment 1

17 years ago
I have code in my tree to rectify this.
(Assignee)

Comment 2

17 years ago
andreas confirmed that the stdurl parser should be fine.
Keywords: nsbeta3
Whiteboard: [nsbeta3]
Target Milestone: --- → M18
(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 47437 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.