mozilla-central cairo-qt build broken - no private/qucomextra_p.h

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Piotr Maliński, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux 2.6.27-gentoo-r2; X11; x86_64; pl) KHTML/3.5.10 (like Gecko) (Gentoo)
Build Identifier: 

mozilla-central checkout, 49a032846a3a tip fails to build on linux amd64 (probably) due to a missing file - private/qucomextra_p.h


Reproducible: Always

Steps to Reproduce:
make -f client.mk build

for .mozconfig
ac_add_options --enable-application=browser

ac_add_options --enable-default-toolkit=cairo-qt
ac_add_options --enable-optimize
ac_add_options --disable-tests

ac_add_options --disable-installer
ac_add_options --disable-crashreporter
ac_add_options --disable-javaxpcom
ac_add_options --disable-printing
ac_add_options --disable-embedding-tests
ac_add_options --disable-elf-dynstr-gc

Actual Results:  
c++ -o moc_mozqwidget.o -c -I../../../dist/include/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_COM_OBSOLETE -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DZLIB_INTERNAL -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -D_IMPL_NS_WIDGET -D_BSD_SOURCE -I../../../widget/src/xpwidgets -I.  -I. -I. -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/gfx -I../../../dist/include/pref -I../../../dist/include/dom -I../../../dist/include/necko -I../../../dist/include/uconv -I../../../dist/include/intl -I../../../dist/include/imglib2 -I../../../dist/include/view -I../../../dist/include/content -I../../../dist/include/layout -I../../../dist/include/util -I../../../dist/include/locale -I../../../dist/include/thebes -I../../../dist/include/cairo -I../../../dist/include/unicharutil -I../../../dist/include   -I../../../dist/include/widget -I/home/piotr/svn/qt/mozilla-central/dist/include/nspr     -I/home/piotr/svn/qt/mozilla-central/dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtUiTools -I/usr/include/qt4/QtCore      -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/moc_mozqwidget.pp moc_mozqwidget.cpp
In file included from moc_mozqwidget.cpp:15:
../../../dist/include/system_wrappers/private/qucomextra_p.h:3:39: error: private/qucomextra_p.h: Nie ma takiego pliku ani katalogu
moc_mozqwidget.cpp:17:2: error: #error "This file was generated using the moc from 3.3.8b. It"
moc_mozqwidget.cpp:18:2: error: #error "cannot be used with the include files from this version of Qt."
moc_mozqwidget.cpp:19:2: error: #error "(The moc has changed too much.)"
moc_mozqwidget.cpp:22: error: no ‘const char* MozQWidget::className() const’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:27: error: ‘QMetaObject* MozQWidget::metaObj’ is not a static member of ‘class MozQWidget’
moc_mozqwidget.cpp:28: error: ‘QMetaObjectCleanUp’ does not name a type
moc_mozqwidget.cpp:31: error: redefinition of ‘static QString MozQWidget::tr(const char*, const char*)’
mozqwidget.h:12: error: ‘static QString MozQWidget::tr(const char*, const char*)’ previously defined here
moc_mozqwidget.cpp:39: error: redefinition of ‘static QString MozQWidget::trUtf8(const char*, const char*)’
mozqwidget.h:12: error: ‘static QString MozQWidget::trUtf8(const char*, const char*)’ previously defined here
moc_mozqwidget.cpp:50: error: no ‘QMetaObject* MozQWidget::staticMetaObject()’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:68: error: no ‘void* MozQWidget::qt_cast(const char*)’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:75: error: ‘QUObject’ has not been declared
moc_mozqwidget.cpp:75: error: no ‘bool MozQWidget::qt_invoke(int, int*)’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:80: error: ‘QUObject’ has not been declared
moc_mozqwidget.cpp:80: error: no ‘bool MozQWidget::qt_emit(int, int*)’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:86: error: no ‘bool MozQWidget::qt_property(int, int, QVariant*)’ member function declared in class ‘MozQWidget’
moc_mozqwidget.cpp:91: error: no ‘bool MozQWidget::qt_static_property(QObject*, int, int, QVariant*)’ member function declared in class ‘MozQWidget’
gmake[6]: *** [moc_mozqwidget.o] Błąd 1

Comment 1

10 years ago
(In reply to comment #0)
> In file included from moc_mozqwidget.cpp:15:
> ../../../dist/include/system_wrappers/private/qucomextra_p.h:3:39: error:
> private/qucomextra_p.h: Nie ma takiego pliku ani katalogu
> moc_mozqwidget.cpp:17:2: error: #error "This file was generated using the moc
> from 3.3.8b. It"
> moc_mozqwidget.cpp:18:2: error: #error "cannot be used with the include files
> from this version of Qt."
> moc_mozqwidget.cpp:19:2: error: #error "(The moc has changed too much.)"

Have you compiled with qt3 files before? Does cleaning up the tree help?

Comment 2

10 years ago
Looks like it's finding moc from Qt 3 instead of Qt 4.
You have to add --with-qtdir=<your qt4 dir> to configure (.mozconfig), then it should work.

Setting to INCOMPLETE unless you find it still happening when pointing to the correct moc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.