Update DOMi compat info for SeaMonkey 2.0a3

VERIFIED FIXED in mozilla1.9.1b3

Status

Other Applications
DOM Inspector
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

Trunk
mozilla1.9.1b3

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

9 years ago
Current DOMi should be updated to be compatible with up to SeaMonkey 2.0a3 both in the install.rdf on trunk and the AMO settings for the 2.0.1 version.

Preferably we should refrain from using the "pre" in the future there, as when cutting the current 2.0a2, I noticed that the included DOMi version now states it's not compatible that the release but only the "pre" versions. If we use the version number of 2.0a3 without the "pre" now, we won't run into that again next time. :)
(Assignee)

Updated

9 years ago
Duplicate of this bug: 467746
Depends on: 467746
Blocks: 467746
Severity: normal → major
No longer depends on: 467746
Flags: blocking-seamonkey2.0a3?
Summary: Update DOMi compat info for SeaMonkey 2.0a3 → Update DOMi compat info for SeaMonkey 2.0a3 and Thunderbird 3.0b2
No longer blocks: 467746
Depends on: 467746
Serge, I already have a bug filed for Thunderbird with a patch.
Summary: Update DOMi compat info for SeaMonkey 2.0a3 and Thunderbird 3.0b2 → Update DOMi compat info for SeaMonkey 2.0a3
I've mentioned in the past that it is rs=sdwilsh for version bumps to the *current* version in trunk.  Please don't drop the pre because then I can't actually upload it to amo.

Just ping me on irc to get the amo bits flipped properly.
(In reply to comment #3)
> I've mentioned in the past that it is rs=sdwilsh for version bumps to the
> *current* version in trunk.

Could this be done automatically then ?
Maybe something like http://hg.mozilla.org/comm-central/rev/f20077c36869...
Then I can't build domi outside of a comm-central tree, so no.
(In reply to comment #5)

Then, could "KaiRo" do it "manually" as part of the "release" steps ?
I mean "at the same time the version is bumped for SeaMonkey itself" !
(Assignee)

Comment 7

9 years ago
(In reply to comment #3)
> I've mentioned in the past that it is rs=sdwilsh for version bumps to the
> *current* version in trunk.  Please don't drop the pre because then I can't
> actually upload it to amo.

You can upload it to AMO without the "pre", as we let AMO admins add the final version at the same time as the "pre" one for SeaMonkey - intentionally, exactly for that reason.
(Assignee)

Comment 8

9 years ago
Pushed the update to the max allowed by AMO as http://hg.mozilla.org/dom-inspector/rev/41ca614f6f92 and sdwildsh did the developer panel change, so this is fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(In reply to comment #8)

       7 -        <em:minVersion>2.0a</em:minVersion>
       9 +        <em:minVersion>2.0a1pre</em:minVersion>

Shouldn't that be "2.0a1" only ? (to support both)

(Fwiw, this remark would apply to TB too...)
Assignee: sdwilsh → kairo
Target Milestone: --- → mozilla1.9.1b3
(Assignee)

Comment 10

9 years ago
Serge:
We never had a "2.0a" in any builds, the earliest toolkit-based builds we had were "2.0a1pre", that why I made that change as well. AMO and toolkit correctly calculate "2.0a1pre < 2.0a1" though, they made them that intelligent :)
(In reply to comment #10)
> AMO and toolkit correctly calculate "2.0a1pre < 2.0a1" though, they made them that intelligent :)

Good then :-)

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20081230 SeaMonkey/2.0a3pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/6201c0669e15
 +http://hg.mozilla.org/comm-central/rev/2854a16a867f)

V.Fixed
Status: RESOLVED → VERIFIED
Flags: blocking-seamonkey2.0a3?
You need to log in before you can comment on or make changes to this bug.