Pound sign "#" in attachment file name makes the attachment unusable (imap)

RESOLVED DUPLICATE of bug 370951

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 370951
9 years ago
9 years ago

People

(Reporter: Jost Diederichs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081203 Shredder/3.0b2pre

an imap mail message containing an attachment with a file name that has a pound sign "#" cannot be successfully opened, saved or dragged to the desktop.

I confirmed this on the latest windows and Linux builds of shredder. 

Reproducible: Always

Steps to Reproduce:
1. Send a message with an attachment where the file name contains a # sign to an imap account that your access from shredder. 
2. Open the imap mail message from shredder and try to open the attachment. 
3. There is no error, it will simply not open when double clicked.
4. Saving the attachment works only if the # sign is removed from the file name in the save-as dialog.
5. Dragging the file to the Desktop creates a broken file on the Desktop

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370951
You need to log in before you can comment on or make changes to this bug.